|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11.1 Information Library|
- list directory contents on an NTFS file system
ntfsls [options] device
The ntfsls utility lists information about the files specified by the PATH option (the root directory by default). device (see Synopsis) is the special file corresponding to the device (for example, /dev/dsk/c0d0p0num) or an NTFS image file.
Supported options are listed below. Most options have both single-letter and full-name forms. Multiple single-letter options that do not take an argument can be combined. For example, -fv is the equivalent of -f -v. A full-name option can be abbreviated to a unique prefix of its name.
Display all files. If this option is not specified file names in the POSIX namespace are not displayed.
Append one of the indicators shown below to entries.
* / = @ |
Force execution. For example, this option is necessary to run on an NTFS partition stored in a normal file.
Display usage information and exit.
Display the inode number of each file. This is the MFT reference number, in NTFS terminology.
Use a long listing format.
The directory whose contents to list or the file (including the path) about which to display information.
Suppress some debug, warning, and error messages.
Show the contents of all directories beneath the specified directory.
Unless this options is specified, all files beginning with a dollar sign character will not be listed, as these files are usually system files.
Display more debug, warning, and error messages.
Display the ntfsls version number and exit.
Display short file names, that is, files in the DOS namespace, instead of long file names, that is, files in the WIN32 namespace.
See attributes(5) for descriptions of the following attributes:
This version of ntfsls was written by Lode Leroy, Anton Altaparmakov, Richard Russon, Carmelo Kintana and Giang Nguyen.