|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11.1 Information Library|
- move a directory
/usr/sbin/mvdir dirname name
mvdir moves directories within a file system. dirname must be a directory. If name does not exist, it will be created as a directory. If name does exist, and is a directory, dirname will be created as name/dirname. dirname and name may not be on the same path; that is, one may not be subordinate to the other. For example:
example% mvdir x/y x/z
is legal, but
example% mvdir x/y x/y/z
The name of the directory that is to be moved to another directory in the filesystem.
The name of the directory into which dirname is to be moved. If name does not exist, it will be created. It may not be on the same path as dirname.
See largefile(5) for the description of the behavior of mvdir when encountering files greater than or equal to 2 Gbyte ( 231 bytes).
See attributes(5) for descriptions of the following attributes: