|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11.1 Information Library|
- Image Packaging System system repository configuration
/usr/lib/pkg.sysrepo -p port [-c cache_dir] [-s cache_size] [-w http_proxy] [-W https_proxy]
pkg.sysrepo is used to generate the configuration files for the Image Packaging System (IPS) system repository. pkg.sysrepo is called by the svc:/application/pkg/system-repository Service Management Facility (SMF) service. Changes in configuration should be made to the properties in the SMF service.
The system repository is responsible for providing access to the package repositories configured in a reference image through a centralized proxy. Publisher configuration changes made to that reference image are seen immediately by any clients configured to use the system repository.
The system repository is primarily used in the global zone to allow non-global zones to access the repositories configured in the global zone. The SMF services svc:/application/pkg/zones-proxyd and svc:/application/pkg/zones-proxy-client are responsible for providing the transport between non-global zones and the global zone. This transport is only used by pkg(5).
Note that only http, https, and v4 file repositories and p5p archives are supported. Older file repository formats are not supported. See pkgrepo(1) for more information about repository versions.
The following options are supported:
Specify the absolute path to a directory that should be used by the system repository for caching responses from the publishers configured.
By default, a file-cache is used. However, the special value memory can be used to indicate the an in-memory cache should be used. The special value None can be used to indicate that the system repository should not perform any caching. This setting should be configured using the config/cache_dir SMF property.
Specify the port that the system repository should use to listen for requests. This setting should be configured using the config/port SMF property.
An integer value in megabytes that defines the maximum cache size of the system repository. This setting should be configured using the config/cache_max SMF property.
A string of the form scheme://hostname[:port] that defines a web proxy that the system repository can use to access http-based package repositories. This setting can be configured using the config/http_proxy SMF property.
A string of the form scheme://hostname[:port] that defines a web proxy that the system repository can use to access https-based package repositories. This setting can be configured using the config/https_proxy SMF property.
Example 1 Enabling the System Repository
$ svcadm enable svc:/application/pkg/system-repository
The following exit values are returned:
Command failed to write a valid configuration.
Invalid command line options were specified.
An unanticipated exception occurred.
See attributes(5) for descriptions of the following attributes: