|Skip Navigation Links|
|Exit Print View|
|man pages section 5: Standards, Environments, and Macros Oracle Solaris 11 Express 11/10|
- ipkg branded zone
The ipkg brand uses the branded zones framework described in brands(5) to run zones installed with the same software as is installed in the global zone. The system software must always be in sync with the global zone when using a ipkg brand. The system software packages within the zone are managed using the image packaging system. See pkg(5).
The ipkg brand supports the whole root non-global zone model. All of the required system software and any additional packages are installed into the private file systems of the zone. The zone must reside on its own zfs(1M) dataset and only ZFS is supported. The ZFS dataset is created automatically when the zone is installed or attached. If a ZFS dataset cannot be created, the zone is not installed or attached.
The following ipkg brand-specific subcommand options are supported by zoneadm(1M).
Attach the specified ipkg branded zone image into the zone. If neither -a or -d is specified, the zone's zonepath is assumed to already be properly installed with the zone's files. zoneadm checks package levels on the machine to which the zone is to be attached. If the packages that the zone depends on from the global zone are different (have different revision numbers) from the dependent packages on the source machine, zoneadm reports these conflicts and does not perform the attach. If the destination system has only newer dependent packages (higher revision numbers) than those on the source system, you can use the -uoption to update the attached zone to match the revision of the packages that exist on the new system. With -u, as in the default behavior, zoneadm does not perform an attach if outdated packages are found on the target system.
The path to the zonepath directory of a ipkg branded zone's zonepath.
Update the packages for the zone's system software to match the global zone.
The ipkg brand installer supports installing the zone from either the software repository or from an image of an installed system running the same release. This can be a cpio(1) or pax(1) xustar archive. The cpio archive can be compressed with gzip or bzip2. The image can also be a path to the top-level of a system's root tree, or a pre-existing zone path.
If neither the -a or -d option is used, the zone is installed from the repository.
To install the zone from a system image either the -a or -d is required. Either the -u or -p option is also required in this case.
The path to the certificate file needed for accessing the repository.
The path to the root directory of an installed system. If path is a hyphen (-), the zonepath is presumed to be already populated with the system image
The name of a package to install into the zone. The -e option is used to specify an additional package to install, in addition to the base set of software which is always installed into the zone. Multiple -e options can be used
The path to the key file needed for accessing the repository.
The name of a software repository publisher and its associated URI to use to install the zone instead of the default global zone's repository.
Preserve the system configuration after installing the zone.
Run sys-unconfig(1M) on the zone after installing it.
Verbose output from the install process.
See attributes(5) for a description of the following attributes:
pkg(5), available in the IPS consolidation