|Skip Navigation Links|
|Exit Print View|
|man pages section 5: Standards, Environments, and Macros Oracle Solaris 11 Express 11/10|
- macros to format Reference Manual pages
nroff -mansun filename...
troff -mansun filename...
These macros are used to lay out the reference pages in this manual. Note: if filename contains format input for a preprocessor, the commands shown above must be piped through the appropriate preprocessor. This is handled automatically by man(1). See the ``Conventions'' section.
Any text argument t may be zero to six words. Quotes may be used to include SPACE characters in a “word”. If text is empty, the special treatment is applied to the next input line with text to be printed. In this way .I may be used to italicize a whole line, or .SB may be used to make small bold letters.
A prevailing indent distance is remembered between successive indented paragraphs, and is reset to default value upon reaching a non-indented paragraph. Default units for indents i are ens.
Type font and size are reset to default values before each paragraph, and after processing font and size setting macros.
These strings are predefined by -mansun:
`®', `(Reg)' in nroff.
Change to default type size.
* n.t.l. = next text line; p.i. = prevailing indent
When formatting a manual page, mansun examines the first line to determine whether it requires special processing. For example a first line consisting of:
indicates that the manual page must be run through the tbl(1) preprocessor.
A typical manual page for a command or function is laid out as follows:
The name of the command or function, which serves as the title of the manual page. This is followed by the number of the section in which it appears.
The name, or list of names, by which the command is called, followed by a dash and then a one-line summary of the action performed. All in Roman font, this section contains no troff(1) commands or escapes, and no macro requests. It is used to generate the windex database, which is used by the whatis(1) command.
The syntax of the command and its arguments, as typed on the command line. When in boldface, a word must be typed exactly as printed. When in italics, a word can be replaced with an argument that you supply. References to bold or italicized items are not capitalized in other sections, even when they begin a sentence.
Syntactic symbols appear in Roman face:
An argument, when surrounded by brackets is optional.
Arguments separated by a vertical bar are exclusive. You can supply only one item from such a list.
Arguments followed by an ellipsis can be repeated. When an ellipsis follows a bracketed set, the expression within the brackets can be repeated.
If required, the data declaration, or #include directive, is shown first, followed by the function declaration. Otherwise, the function declaration is shown.
A narrative overview of the command or function's external behavior. This includes how it interacts with files or data, and how it handles the standard input, standard output and standard error. Internals and implementation details are normally omitted. This section attempts to provide a succinct overview in answer to the question, "what does it do?"
Literal text from the synopsis appears in constant width, as do literal filenames and references to items that appear elsewhere in the reference manuals. Arguments are italicized.
If a command interprets either subcommands or an input grammar, its command interface or input grammar is normally described in a USAGE section, which follows the OPTIONS section. The DESCRIPTION section only describes the behavior of the command itself, not that of subcommands.
The list of options along with a description of how each affects the command's operation.
A list of files associated with the command or function.
A comma-separated list of related manual pages, followed by references to other published materials.
A list of diagnostic messages and an explanation of each.
A description of limitations, known defects, and possible problems associated with the command or function.
Dale Dougherty and Tim O'Reilly, Unix Text Processing