|Skip Navigation Links|
|Exit Print View|
|man pages section 5: Standards, Environments, and Macros Oracle Solaris 11 Express 11/10|
Standards, Environments, and Macros
- Solaris 10 branded zone
The solaris10 brand uses the branded zones framework described in brands(5) to enable Solaris 10 binary applications to run unmodified on a machine with the latest Solaris Operating System kernel.
The solaris10 brand only supports running the Solaris 10 10/09 (Solaris 10 update 8) release, or later, within the zone.
The solaris10 brand includes the tools necessary to install a Solaris 10 system image into a non-global zone. It also supports the tools necessary to migrate a Solaris 10 native zone to a solaris10 branded zone. The brand supports the execution of 32-bit and 64-bit Solaris 10 applications on either SPARC or x86 machines running the latest Solaris operating system.
The solaris10 brand supports the whole root non-global zone model. All of the required Solaris 10 software and any additional packages are installed into the private file systems of the zone.
The zone must reside on its own zfs(1M) dataset and only ZFS is supported. The ZFS dataset created automatically when the zone is installed or attached. If a ZFS dataset cannot be created, the zone is not installed or attached.
The zonecfg(1M) utility is used to configure a solaris10 branded zone. The SUNWsolaris10 template can be used when creating the zone or the configuration can be set up manually. Once a branded zone has been installed, that zone's brand cannot be changed or removed. The zoneadm(1M) utility is used to report the zone's brand type and administer the zone. The zlogin(1) utility is used to log in to the zone.
The support for delegated ZFS dataset configurations is currently experimental and has not yet been tested. Support for running these zones in a para-virtualized xVM domain is experimental and there are known problems with 64-bit x86 applications within the zone. The /dev/sound device cannot be configured into the branded zone. In addition, mdb(1) and dtrace(1M) are not fully functional when used in the global zone to examine processes executing within a solaris10 branded zone.
The solaris10 brand installer supports installing the zone from an image of an installed Solaris 10 system. This can be a full flash_archive(4), cpio(1), or pax(1) xustar archive. The cpio archive can be compressed with gzip(1) or bzip2(1). The image can also be a level 0 ufsdump(1M), or a path to the top-level of a Solaris 10 system's root directory tree. The zone cannot be installed from standard Solaris 10 distribution media.
To migrate a native zone from a Solaris 10 system to the latest Solaris Operating System kernel, the attach subcommand supports installing the zone from an archive of an installed Solaris 10 native zone. As with the installer, this can be a cpio(1) or pax(1) xustar archive of the zonepath. The cpio archive can be compressed with gzip(1) or bzip2(1). The image can also be a path to the top-level of a Solaris 10 zone's zonepath directory tree. In addition to migrating from a Solaris 10 native zone, the same migration options can be used when migrating a solaris10 branded zone from one host to another. When migrating from Solaris 10, it is possible that the zone is configured as a sparseroot zone. In this case, the zone should be readied on the host before the archive is made. This ensures that the inherited directories are included in the archive.
The following arguments of zoneadm(1M) brand-specific subcommand are supported:
Attach the specified Solaris 10 native zone image into the branded zone. If neither -a or -d is specified, the zone's zonepath is assumed to already be properly installed with the zone's files.
The path to a cpio(1) or pax(1) xustar archive of either an installed Solaris 10 native zone or a solaris10 branded zone's zonepath. cpio archives can be compressed using gzip or bzip2.
The path to the zonepath directory of either an installed Solaris 10 native zone or a solaris10 branded zone's zonepath.
Install the specified Solaris 10 system image into the zone. Either the -u or -p option is required and either the -a or -d option is required.
The path to a flash_archive(4), cpio(1), pax(1) xustar archive, or a level 0 ufsdump(1M) of an installed Solaris 10 system. The cpio archives can be compressed using gzip or bzip2.
The path to the root directory of an installed Solaris 10 system.
Preserve the system configuration after installing the zone.
Run sys-unconfig(1M) on the zone after installing it.
Verbose output from the install process.
The solaris10 zone only supports user-level Solaris 10 applications. You cannot use Solaris 10 device drivers or Solaris 10 kernel modules from inside a solaris10 zone. However, depending on the kernel module, you might be able to use the latest Solaris kernel module version with the Solaris 10 user-level application.
See attributes(5) for a description of the following attributes:
cpio(1), mdb(1), pax(1), zlogin(1), dtrace(1M), ufsdump(1M), sys-unconfig(1M), zfs(1M), zoneadm(1M), zonecfg(1M), flash_archive(4), attributes(5), brands(5), zones(5)