|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Information Library|
- convert device speeds
#include <sys/pccard.h> int32_t csx_ConvertSpeed(convert_speed_t *cs);
Solaris DDI Specific (Solaris DDI)
Pointer to a convert_speed_t structure.
This function is a Solaris-specific extension that provides a method for clients to convert from one type of device speed representation to another, that is, from devspeed format to nS and vice versa.
The structure members of convert_speed_t are:
uint32_t Attributes; uint32_t nS; uint32_t devspeed;
The fields are defined as follows:
This is a bit-mapped field that identifies the type of speed conversion to be performed. The field is defined as follows:
Converts nS to devspeed format
Converts devspeed format to nS
If CONVERT_NS_TO_DEVSPEED is set, the value in the nS field is converted to a devspeed format and returned in the devspeed field.
If CONVERT_DEVSPEED_TO_NS is set, the value in the devspeed field is converted to an nS value and returned in the nS field.
Invalid nS or devspeed.
Bad Attributes value.
No PCMCIA hardware installed.
This function may be called from user or kernel context.
PC Card 95 Standard, PCMCIA/JEIDA