|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Information Library|
- return information on supported hardware interrupt types
#include <sys/types.h> #include <sys/conf.h> #include <sys/ddi.h> #include <sys/sunddi.h> int ddi_intr_get_supported_types(dev_info_t *dip, int *typesp);
Solaris DDI specific (Solaris DDI)
Pointer to dev_info structure
Pointer to supported interrupt types
The ddi_intr_get_supported_types() function retrieves the interrupt types supported by a particular hardware device and by the system software. Upon successful return, the supported types are returned as a bit mask in the integer pointed to by the typesp argument. See <sys/ddi_intr.h> for a list of interrupts that can be returned by a hardware device.
For PCI devices that support MSI and/or MSI-X based hardware, this interface returns only the interrupt types that are supported by all the hardware in the path to the hardware device.
An interrupt type is usable by the hardware device if it is returned by the ddi_intr_get_supported_types() function. The device driver can be programmed to use one of the returned interrupt types to receive hardware interrupts.
The ddi_intr_get_supported_types() function returns:
On encountering invalid input parameters.
Returned when the hardware device is found not to support any hardware interrupts.
The ddi_intr_get_supported_types() function can be called from user or kernel non-interrupt context.
See attributes(5) for descriptions of the following attributes:
The ddi_intr_get_supported_types() function can be called by the device driver even at any time if the driver has added an interrupt handler for a given interrupt type.
Soft interrupts are always usable and are not returned by this interface.
Any consumer of this interface should verify that the return value is not equal to DDI_SUCCESS. Incomplete checking for failure codes could result in inconsistent behavior among platforms.