|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Information Library|
- put a message on a queue
#include <sys/stream.h> int putq(queue_t *q, mblk_t *bp);
Architecture independent level 1 (DDI/DKI).
Pointer to the queue to which the message is to be added.
Message to be put on the queue.
The putq() function is used to put messages on a driver's queue after the module's put routine has finished processing the message. The message is placed after any other messages of the same priority, and flow control parameters are updated. If QNOENB is not set, the service routine is enabled. If no other processing is done, putq() can be used as the module's put routine.
The putq() function returns 1 on success and 0 on failure.
Upon failure, the caller should call freemsg(9F) to free the pointer to the message block.
The putq() function can be called from user, interrupt, or kernel context.
See the datamsg(9F) function page for an example of putq().