|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Information Library|
- change information about a queue or band of the queue
#include <sys/stream.h> int strqset(queue_t *q, qfields_t what, unsigned char pri, intptr_t val);
Architecture independent level 1 (DDI/DKI).
Pointer to the queue.
Field of the queue structure (or the specified priority band) to return information about. Valid values are one of:
High water mark.
Low water mark.
Largest packet accepted.
Smallest packet accepted.
Priority band of interest.
The value for the field to be changed.
The strqset() function gives drivers and modules a way to change information about a queue or a particular band of a queue without directly accessing STREAMS data structures.
On success, 0 is returned. EINVAL is returned if an undefined attribute is specified.
The strqset() function can be called from user, interrupt, or kernel context.
When lowering existing values, set QMINPSZ before setting QMAXPSZ; when raising existing values, set QMAXPSZ before setting QMINPSZ.