|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Information Library|
- get information about a queue or band of the queue
#include <sys/stream.h> int strqget(queue_t *q, qfields_t what, unsigned char pri, void *valp);
Architecture independent level 1 (DDI/DKI).
Pointer to the queue.
Field of the queue structure for (or the specified priority band) to return information about. Valid values are one of:
High water mark.
Low water mark.
Largest packet accepted.
Smallest packet accepted.
Approximate size (in bytes) of data.
Priority band of interest.
The address of where to store the value of the requested field.
The strqget() function gives drivers and modules a way to get information about a queue or a particular band of a queue without directly accessing STREAMS data structures, thus insulating them from changes in the implementation of these data structures from release to release.
On success, 0 is returned and the value of the requested field is stored in the location pointed to by valp. An error number is returned on failure.
The strqget() function can be called from user, interrupt, or kernel context.