|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Information Library|
- determine if there is a need to translate M_IOCTL contents.
#include <sys/stream.h> uint_t IOC_CONVERT_FROM(struct iocblk *iocp);
Solaris DDI Specific (Solaris DDI)
A pointer to the M_IOCTL control structure.
The IOC_CONVERT_FROM macro is used to see if the contents of the current M_IOCTL message had its origin in a different C Language Type Model.
The IOC_CONVERT_FROM() function returns the following values:
This is an LP64 kernel and the M_IOCTL originated in an ILP32 user process.
The M_IOCTL message uses the same C Language Type Model as this calling module or driver.
The IOC_CONVERT_FROM() macro can be called from user, interrupt, or kernel context.