|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Information Library|
- get the name-value pair list for the VF device
#include <sys/sunddi.h> int pci_plist_getvf(pci_param_t param, uint16_t vf_index, pci_plist_t *vfplist_p);
0 through #VFS -1
A pointer to pci_param_plist_t where a non—null plist_p is returned on successful return
The vfplist_p returned by pci_plist_getvf() is similar to nvlist_t and contains the name-value pairs for the VF (Virtual Function) device. The pci_plist_t supports the following data types:
uchar, int8_t, uint8_t, int16_t uint16_t, int32_t, uint32_t, int64_t, uint64_t, char *, pci_plist_t
Arrays of the above data types are supported.
There is no name-value list for VF device.
The pci_param_get() function can be called from kernel non-interrupt context.
See attributes(5) for descriptions of the following attributes: