|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Information Library|
- free an allocated SCSI packet and its DMA resource
#include <sys/scsi/scsi.h> void scsi_destroy_pkt(struct scsi_pkt *pktp);
Solaris DDI specific (Solaris DDI).
Pointer to a scsi_pkt(9S) structure.
The scsi_destroy_pkt() function releases all necessary resources, typically at the end of an I/O transfer. The data is synchronized to memory, then the DMA resources are deallocated and pktp is freed.
The scsi_destroy_pkt() function may be called from user, interrupt, or kernel context.
Example 1 Releasing resources