|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Information Library|
- easier DMA setup for use with virtual addresses
#include <sys/ddi.h> #include <sys/sunddi.h> int ddi_dma_addr_setup(dev_info_t *dip, struct as *as, caddr_t addr, size_t len, uint_t flags, int (*waitfp) (caddr_t), caddr_t arg, ddi_dma_lim_t * lim, ddi_dma_handle_t *handlep);
This interface is obsolete. ddi_dma_addr_bind_handle(9F) should be used instead.
A pointer to the device's dev_info structure.
A pointer to an address space structure. Should be set to NULL, which implies kernel address space.
Virtual address of the memory object.
Length of the memory object in bytes.
Flags that would go into the ddi_dma_req structure (see ddi_dma_req(9S)).
The address of a function to call back later if resources aren't available now. The special function addresses DDI_DMA_SLEEP and DDI_DMA_DONTWAIT (see ddi_dma_req(9S)) are taken to mean, respectively, wait until resources are available or, do not wait at all and do not schedule a callback.
Argument to be passed to a callback function, if such a function is specified.
Pointer to a DMA handle. See ddi_dma_setup(9F) for a discussion of handle.
See ddi_dma_setup(9F) for the possible return values for this function.
The ddi_dma_addr_setup() can be called from user, interrupt, or kernel context, except when waitfp is set to DDI_DMA_SLEEP, in which case it cannot be called from interrupt context.
See attributes(5) for a description of the following attributes: