|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Information Library|
- setup or tear down the resources for enabling accesses to the PCI Local Bus Configuration space
#include <sys/ddi.h> #include <sys/sunddi.h> int pci_config_setup(dev_info_t *dip, ddi_acc_handle_t *handle);
void pci_config_teardown(ddi_acc_handle_t *handle);
Solaris DDI specific (Solaris DDI).
Pointer to the device's dev_info structure.
Pointer to a data access handle.
pci_config_setup() sets up the necessary resources for enabling subsequent data accesses to the PCI Local Bus Configuration space. pci_config_teardown() reclaims and removes those resources represented by the data access handle returned from pci_config_setup().
Successfully setup the resources.
Unable to allocate resources for setup.
pci_config_setup() must be called from user or kernel context. pci_config_teardown() can be called from any context.
These functions are specific to PCI bus device drivers. For drivers using these functions, a single source to support devices with multiple bus versions may not be easy to maintain.
See attributes(5) for descriptions of the following attributes:
IEEE 1275 PCI Bus Binding