|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Information Library|
- remove client from Card Services list
#include <sys/pccard.h> int32_t csx_DeregisterClient(client_handle_t ch);
Solaris DDI Specific (Solaris DDI)
Client handle returned from csx_RegisterClient(9F).
This function removes a client from the list of registered clients maintained by Card Services. The Client Handle returned by csx_RegisterClient(9F) is passed in the client_handle_t argument.
The client must have returned all requested resources before this function is called. If any resources have not been released, CS_IN_USE is returned.
Client handle is invalid.
Resources not released by this client.
No PCMCIA hardware installed.
This function may be called from user or kernel context.
PC Card 95 Standard, PCMCIA/JEIDA
Clients should be prepared to receive callbacks until Card Services returns from this request successfully.