|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Information Library|
- indicate that a reference to a network protocol is no longer required
#include <sys/neti.h> int net_protocol_release(net_data_t *net);
Solaris DDI specific (Solaris DDI).
value returned from a successful call to net_protocol_lookup(9F).
The net_protocol_release() function indicates to the network information framework that the caller is no longer interested in any knowledge about the network protocol to which the parameter being passed through applies.
The net_protocol_release() function returns:
The value passed in is unknown to this framework.
Unsuccessful because this function has been called too many times.
The net_protocol_release() function may be called from user, kernel, or interrupt context.
See attributes(5) for descriptions of the following attributes: