|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Information Library|
- get the name-value pair list for the PF device
#include <sys/sunddi.h> int pci_plist_get(pci_param_t param, pci_plist_t *plist_p);
A pointer to pci_plist_t where a non—null plist_p is returned on successful return
The plist_p returned by pci_plist_get() is similar to nvlist_t and contains the name-value pairs for the PF (Physical Function) device. The pci_plist_t supports the following data types:
int8_t, uint8_t, int16_t, uint16_t, int32_t, uint32_t, int64_t, uint64_t, char *, pci_plist_t
Arrays of the above data types are supported except pci_plist_t.
There is no name-value list for PF device.
See attributes(5) for descriptions of the following attributes: