/usr/lib/fm/notify/asr-notify [- ]
asr-notify is a daemon that subscribes to Fault Management life cycle events and produces HTTPS/XML notifications based on a set of notification preferences that are stored in the SMF service configuration repository.
The messages will be sent to the Oracle Auto Service Request (ASR) service offering once the service has been registered using the asradm(1M) command or by setting SMF auto registration properties. If the auto registration properties are set, the service will attempt to register on either startup or refresh. If registration fails, the service will go into maintenance mode. If registration is successful, the SMF auto registration properties will be deleted.
asr-notify is managed by the service management facility, smf(5), under the service FMRI:
ASR notification preferences are set using svccfg(1M).
The following service properties can be set:
This is an astring property that defaults to /. When set, the specified root directory will be used for all pathnames evaluated by asr-notify.
This is an integer property that sets the number of seconds to wait for HTTP connections before generating an error.
This is an astring property that sets the endpoint URL used for registration and all message telemetry. The endpoint URL can be set to a local ASR Manager that will aggregate telemetry from many hosts instances. If not set, then all telemetry will be sent directly to the Oracle Auto Service Request service.
This is an astring property that is used to set the My Oracle Support user name used for auto registration.
This is an astring property that is used to set the My Oracle Support password used for auto registration.
This is an astring property that is used to set the HTTP proxy hostname:port and needs to be set only if an HTTP proxy is used to connect to the internet.
This is an astring property that is used to set the HTTP proxy user name and needs to be set only if the HTTP proxy requires credentials.
This is an astring property that is used to set the HTTP proxy password and needs to be set only if the HTTP proxy requires credentials.
The service will send the following types of messages:
fault messages when an FMA fault is created
daily heartbeat messages to indicate that the system is still active
running and weekly audit messages to provide a full inventory of operational components
The contents of each message are an XML document that adheres to the ASR message XML schema. Each message starts with a common message header followed by event specific content.
ASR event header information:
XML Element Description ------------ ----------- site-id the serial number of the host sending the event host-id the hostname(1) of the system that the message is about message-uuid a unique id generated for each message message-time local time on the system that generated the message system-id the serial number of the system that the message is about asset-id the registered service tag for the system product-id the unique product identifier for the system product-name the name of the product for the system event element containing fault specific event information
The fault-specific content in the event will be contained within the primary-event-information XML element.
XML Element Description ----------- ----------- message-id the knowledge article message ID event-uuid the FMA event UUID event-time the time that the FMA event was generated severity the severity of the FMA event component element containing list of suspects summary a short summary of the event description event description payload the raw FMA event contents
For each suspect FRU associated with a fault event, a hardware-component element will be included within the component.
XML Element Description ----------- ----------- name the component path name of the FRU serial the FRU serial number part the FRU part number revision the FRU revision level additional-information a list of additional properties containing values such as FRU manufacturer and FRU model
Some faults might be associated with a software issue instead of a hardware issue. In this case, the fault event will contain a software-module element within the component list.
XML Element Description ----------- ----------- name the name or FMRI of the software module in error description a description of the software module error
Heartbeat events do not contain any additional data and audit events contain a list of all hardware-component, software-package, and software-module elements available to the system.
See attributes(5) for descriptions of the following attributes: