man pages section 1M: System Administration Commands

Exit Print View

Updated: July 2014
 
 

svcadm(1M)

Name

svcadm - manipulate service instances

Synopsis

/usr/sbin/svcadm [-v] enable [
-rt] [-s [-T timeout
]] {FMRI | pattern}...
/usr/sbin/svcadm [-v] disable [
-t] [-s [-T timeout]] {
FMRI | pattern}...
/usr/sbin/svcadm [-v] restart [
-s [-T timeout]] {
FMRI | pattern}...
/usr/sbin/svcadm [-v] refresh [
-s [-T timeout]] {
FMRI | pattern}...
/usr/sbin/svcadm [-v] clear [
-s [-T timeout]] {
FMRI | pattern}...
/usr/sbin/svcadm [-v] mark [
-It] [-s [-T timeout
]] instance_state 
     {FMRI | pattern}...
/usr/sbin/svcadm [-v] delegate [-s [-T 
timeout]] restarter_FMRI svc
|inst_FMRI
     [ svc|inst_FMRI ... ]
/usr/sbin/svcadm [-v] milestone [
-d] [-s [-T timeout]] 
milestone_FMRI 

Description

svcadm issues requests for actions on services executing within the service management facility (see smf (5) ). Actions for a service are carried out by its assigned service restarter agent. The default service restarter is svc.startd (see svc.startd(1M)).

Options

The following options are supported:

–v

Print actions verbosely to standard output.

SUBCOMMANDS

SUBCOMMANDS

Common Operations

The subcommands listed below are used during the typical administration of a service instance.

For subcommands taking one or more operands, if the operand specifies a service (instead of a service instance), and that service has only a single instance, svcadm operates on that instance. If an abbreviated FMRI (a fault management resource identifier) or pattern matches more than one service, a warning message is displayed and that operand is ignored. See smf(5).

In the case that the service has more than one instance, svcadm return a non-zero exit status.

enable [–rt ] [–s [–T timeout]] {FMRI | pattern}. . .

Enables the service instances specified by the operands. For each service instance, the assigned restarter will try to bring it to the online state. This action requires permission to modify the “general” property group of the service instance (see smf_security (5)).

If the –r option is specified, svcadm enables each service instance and recursively enables its dependencies.

If the –s option is specified, svcadm enables each service instance and then waits for each service instance to enter the online or degraded state. svcadm will return early if it determines that the service cannot reach these states without administrator intervention.

If the –t option is specified, svcadm temporarily enables each service instance. Temporary enable only lasts until reboot. This action requires permission to modify the “restarter_actions” property group of the service instance (see smf_security (5)). By default, enable is persistent across reboot.

If the –T option is specified along with the –s option, svcadm will wait timeout seconds for the synchronous operation to complete. If timeout seconds pass and the action still has potential, svcadm will return early.

disable [–t] [– s [–T timeout ]] {FMRI | pattern }. . .

Disables the service instance specified by the operands. For each service instance, the assigned restarter will try to bring it to the disabled state. This action requires permission to modify the “general” property group of the service instance (see smf_security (5)).

If the –s option is specified, svcadm disables each service instance and then waits for each service instance to enter the disabled state. svcadm will return early if it determines that the service cannot reach this state without administrator intervention.

If the –t option is specified, svcadm temporarily disables each service instance. Temporary disable only lasts until reboot. This action requires permission to modify the “restarter_actions” property group of the service instance (see smf_security (5)). By default, disable is persistent across reboot.

If the –T option is specified along with the –s option, svcadm will wait timeout seconds for the synchronous operation to complete. If timeout seconds pass and the action still has potential, svcadm will return early.

restart [–s [–T timeout] ] {FMRI | pattern}. . .

Requests that the service instances specified by the operands be restarted. This action requires permission to modify the “restarter_actions” property group of the service instance (see smf_security (5)). Restarting a service is implemented by most restarters as a full service “stop” followed by a “start“.

This subcommand can restart only those services that are in the online or degraded states, as those states are defined in smf(5) .

With the –s option, svcadm will not return until each service instance reaches one of the online, degraded, or maintenance states, but not until first transitioning to an intermediate state.

If the –T option is specified along with the –s option, svcadm will wait timeout seconds for the synchronous operation to complete. If timeout seconds pass and the action still has potential, svcadm will return early.

refresh [–s [–T timeout] ] {FMRI | pattern}. . .

For each service instance specified by the operands, requests that the assigned restarter update the service's running configuration snapshot with the values from the current configuration. Some of these values take effect immediately (for example, dependency changes). Other values do not take effect until the next service restart. See the restarter and service documentation for more information.

If the service is managed by svc.startd(1M), the refresh method will be invoked if it exists to request the service reread its own configuration. For other restarters, see the restarter documentation.

This action requires permission to modify the “restarter_actions” property group of the service instance (see smf_security (5)).

The –s option will cause svcadm to wait until each service instance reaches either the online, maintenance, or degraded states. If any instance cannot transition to one of these states without further administrative action, svcadm will return early.

If the –T option is specified along with the –s option, svcadm will wait timeout seconds for the synchronous operation to complete. If timeout seconds pass and the action still has potential, svcadm will return early.

clear [–s [–T timeout] ] {FMRI | pattern}. . .

For each service instance specified by the operands, if the instance is in the maintenance state, signal to the assigned restarter that the service has been repaired. If the instance is in the degraded state, request that the assigned restarter take the service to the online state. This action requires permission to modify the “restarter_actions” property group of the service instance (see smf_security(5) ).

If the –s option is specified, svcadm will not return until each service instance specified by the operands reaches the online state. If any instance cannot reach that state without further administrative action, svcadm will return early.

If the –T option is specified along with the –s option, svcadm will wait timeout seconds for the synchronous operation to complete. If timeout seconds pass and the action still has potential, svcadm will return early.

Exceptional Operations

The following subcommands are used for service development, management of services by higher level frameworks, and temporary administrative manipulation.

delegate [–s [–T timeout] ] restarter_FMRI svc| inst_FMRI [ svc|inst_FMRI ... ]

Change the restarter assignment for the given inst_FMRI to the restarter specified by restarter_FMRI. The special token master will set the delegated restarter to the master restarter, svc.startd(1M). The special token reset will set the delegated restarter back to the original, file-backed restarter by removing the restarter customization. Redelegation requires a restart operation to take effect. Not all restarters support the same underlying application model, so not all potential delegations will result in a functioning service instance; see the manual page for the specific restarters involved in the operation to determine compatibility.

If the restarter does not exist or is disabled, the service instances will not be delegated and an error will be returned. If the restarter exists but is in an offline or maintenance state, the instances will be delegated but may not transition back to an online state. A warning message will be printed.

If the –s option is specified, svcadm delegates each service instance and then waits for each service instance to enter the online state, if previously online, or waits for the general/restarter property group or property to be updated. svcadm will return early if it determines that the service cannot reach these states without administrator intervention.

If the –T option is specified along with the –s option, svcadm will wait timeout seconds for the synchronous operation to complete. If timeout seconds pass and the action still has potential, svcadm will return early.

mark [–It] [– s [–T timeout ]] instance_state { FMRI | pattern}. . .

If instance_state is “maintenance”, then for each service specified by the operands, svcadm requests that the assigned restarter place the service in the maintenance state. See svc.startd(1M) and inetd(1M) for a detailed description of the actions taken for each restarter.

If instance_state is “degraded”, then for services specified by the operands in the online state, svcadm requests that the restarters assigned to the services move them into the degraded state.

If the –I option is specified, the request is flagged as immediate.

The –t option is only valid for maintenance requests. When this option is specified, the request is flagged as temporary, and its effect will only last until the next reboot.

If the –s option is specified, svcadm will not return until each service instance reaches either the maintenance or degraded state.

milestone [–d] [– s [–T timeout ]] milestone_FMRI

If milestone_FMRI is the keyword “none”, all services other than the master restarter, svc:/system/svc/restarter:default , will be temporarily disabled.

If milestone_FMRI is the keyword “all”, temporary enable and disable requests for all services will be nullified.

If milestone_FMRI is one of the following:


svc:/milestone/single-user:default
svc:/milestone/multi-user:default
svc:/milestone/multi-user-server:default

then temporary enable and disable requests for the indicated service and all services it depends on (directly or indirectly) will be nullified. All other services will be temporarily disabled.

Changing the system's current milestone with the “milestone” subcommand will not change the current run level of the system. To change the system's run level, invoke /usr/sbin/init directly.

This action requires permission to modify the “options_ovr” property group of the svc:/system/svc/restarter:default service instance (see smf_security(5) ).

The –d option immediately changes the milestone to the requested milestone, as above. Additionally, it makes the specified milestone the default boot milestone, which persists across reboot. The default milestone is defined by the options/milestone property on the master restarter, svc:/system/svc/restarter:default. If this property is absent, “all” is the default. This action requires permission to modify the “options” property group of the svc:/system/svc/restarter:default service instance (see smf_security (5)).

If the –T option is specified along with the –s option, svcadm will wait timeout seconds for the synchronous operation to complete. If timeout seconds pass and the action still has potential, svcadm will return early.

If the –s option is specified, svcadm will change the system's milestone and then wait for the transition to the specified milestone to complete. If any service that needs to transition either to the online or disabled in order to reach the milestone cannot make the transition without administrative intervention, svcadm will return early.

Operands

The following operands are supported:

FMRI

An FMRI that specifies one or more instances. FMRIs can be abbreviated by specifying the instance name, or the trailing portion of the service name. For example, given the FMRI:

svc:/network/smtp:sendmail

All the following are valid abbreviations:

sendmail 
:sendmail 
smtp 
smtp:sendmail 
network/smtp

While the following are invalid:

mail
network
network/smt

If the FMRI specifies a service, then the command applies to all instances of that service. Abbreviated forms of FMRIs are unstable, and should not be used in scripts or other permanent tools.

pattern

A pattern that is matched against the FMRIs of service instances according to the “globbing” rules described by fnmatch(5). If the pattern does not begin with “svc:”, then “svc:/” is prepended.

If an abbreviated FMRI or pattern matches more than one service, a warning message is displayed and that operand is ignored.

If multiple FMRI or pattern arguments are provided, no assumptions may be made about the order in which they will be processed. If operations on one FMRI might affect operations on another, as with some dependency relationships, those operations should be specified on separate command lines to enforce ordering.

If the –T option is specified along with the –s option, svcadm will wait timeout seconds for the synchronous operation to complete. If timeout seconds pass and the action still has potential, svcadm will return early.

Examples

Example 1 Restarting a Service Instance

The following command restarts the NFS server. The full FMRI for the default service instance is: svc:/network/nfs/server:default

However, you can abbreviate the full FMRI as follows:

# svcadm restart nfs/server
Example 2 Disabling the Standard HTTP Server

The following command disables the standard HTTP server, using an abbreviated FMRI:


$ svcadm disable http
Example 3 Enabling an Instance and Its Dependent Instances

The following command enables the foo:bar instance, and all instances on which it depends:


$ svcadm enable -r foo:bar
Example 4 Synchronously enabling an instance

The following command enables the foo:bar instance. The command will not return until the instance comes online or svcadm determines it is not possible for the service to come online.


$ svcadm enable -s foo:bar
Example 5 Restricting and Restoring the Running Services

The following command restricts the running services to single user mode:


# svcadm milestone milestone/single-user

The following command restores the running services:

# svcadm milestone all

Exit Status

The following exit values are returned:

0

Successful completion.

1

A fatal error occurred. One or more error messages are displayed on standard error.

2

Invalid command line options were specified.

3

svcadm determined that a service instance that it was waiting for could not reach the desired state without administrator intervention due to a problem with the service instance itself.

4

svcadm determined that a service instance that it was waiting for could not reach the desired state without administrator intervention due to a problem with the service's dependencies.

5

svcadm reached the timeout while waiting for a service instance without the instance reaching the desired state despite having the potential to do so.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Availability
system/core-os
Interface Stability
See below.

The interactive output is Uncommitted. The invocation and non-interactive output are Committed.

See also

svcprop(1), svcs (1), inetd(1M), init(1M), svccfg(1M), svc.startd(1M), libscf (3LIB), contract (4), attributes (5), smf(5) , smf_security(5)

Notes

The amount of time svcadm will spend waiting for services and their dependencies to change state is implicitly limited by their method timeouts. For example, a service using the default restarter whose start method hangs will be transitioned to the maintenance state when its timeout expires. svcadm will then consider it impossible for this service to come online without administrator intervention.

Attempts to synchronously enable a service which depends (directly or indirectly) on a file may fail with an exit status indicating that dependencies are unsatisfied if the caller does not have the privileges necessary to search the directory containing the file. This limitation may be removed in a future Solaris release.