man pages section 1M: System Administration Commands

Exit Print View

Updated: July 2014
 
 

sysconfig(1M)

Name

sysconfig - unconfigure or reconfigure a Solaris instance

Synopsis

/usr/sbin/sysconfig
/usr/sbin/sysconfig configure [-s] [
-c config_profile.xml | dir]
     [--destructive] [-g <grouping
>,<grouping>]
/usr/sbin/sysconfig unconfigure [-s] [
--destructive]
     [-g <grouping>,<
grouping>]
/usr/sbin/sysconfig unconfigure [-s] [
-g system] [--destructive]
--include-site-profile
/usr/sbin/sysconfig create-profile [-o 
output_file [-l logfile]
     [-v verbosity] [-b] [
-g <grouping>,<grouping>]

Description

The sysconfig utility is the interface for unconfiguring and reconfiguring a Solaris instance. A Solaris instance is defined as a boot environment in either a global or a non-global zone. Users are able to unconfigure particular, predefined sub-systems. The sub-systems of a system that are configurable re referred to as "functional groupings." A functional grouping is a service or collection of services that are configured or unconfigured when the utility is executed.

There are three operations that are performed using the sysconfig utility: unconfiguration, configuration, and profile creation.

When sysconfig is called with the unconfigure subcommand, the system is unconfigured and left in an unconfigured state.

System configuration can occur either interactively or non-interactively. If the configure sub-command is invoked without a profile, an interactive interface is activated and walks the user through the system configuration process. If the configure subcommand is invoked with a profile, then the configuration reads the profile and the configuration occurs non-interactively. The result in either case is a new configuration for the requested functional grouping.

Configuration and reconfiguration are synonymous. The reconfigure subcommand is an alias for the configure subcommand.

The sysconfig command can also be used to generate a system configuration profile using the create-profile subcommand. The resulting profile is used with the sysconfig configure subcommand to configure functional groupings non-interactively. Valid profile names include an .xml extension.

Configuration of a system can be performed either interactively, using the System Configuration Interactive (SCI) Tool, or non-interactively, using a system configuration profile.

The SCI tool configures the target system in an interactive way using a text user interface. It can also be used to collect information generated by the user that describes the desired configuration of the target system. The tool then generates a system configuration profile containing the desired system configuration.

The SCI tool supports configuration of freshly installed or unconfigured systems. It is designed to provide system configuration for newly created non-global zones and during text installation. If there is a need to modify the configuration of an already configured system utilizing SCI tool, such a system has to be unconfigured first before SCI tool can run.

Besides using sysconfig to perform system configurations, individual functional groupings can be reconfigured and unconfigured. The functional groupings that can be configured on a system are date_time, network, naming_services, location, users, identity, support, and keyboard. The system grouping will configure or unconfigure all functional groupings. Groupings can also be unconfigured and left in an unconfigured state. The default values for unconfigured groupings are shown below.

The following groupings are configurable.

Grouping | Components            | Unconfigured Stat
------------------------------------------------------------
identity        | system nodename       | unknown
------------------------------------------------------------
keyboard        | Keyboard              | U.S. English
------------------------------------------------------------
naming_services | DNS, NIS and LDAP     | No network naming
                | clients, nsswitch     | services
------------------------------------------------------------
network         | network               | No network
------------------------------------------------------------
location        | timezone              | UTC
                | locale                | C locale
------------------------------------------------------------
support         | ASR                   | ASR disabled
                | OCM                   | Disconnected Mode
------------------------------------------------------------
system          | all groupings         | all groupings
                |                       | unconfigured
------------------------------------------------------------
users           | root                  | Empty root password
                | initial user account  | Remove user account
------------------------------------------------------------

The sysconfig utility makes use of the Solaris Management Facility (SMF) to centralize configuration information. The data generated by a system configuration operation is an administrative customization to the SMF repository and are stored at the admin layer of SMF repository. Profiles generated during configuration are archived in /etc/svc/profile/sysconfig. System configuration information that users store in other SMF layers will be will be overridden by the admin layer.

Sub Commands

This section describes supported subcommands and their associated options.

unconfigure [–s] [– g system] [–-destructive]

Unconfigure a system and leave it in the unconfigured state.

–s

Shut the system down after the unconfiguration completes.

–g grouping

The grouping to unconfigure. If –g is not specified, all groupings will be unconfigured, resulting in a system unconfiguration. The user will be queried for confirmation before system unconfiguration occurs.

–-destructive

Do not preserve system data that is normally preserved during unconfiguration. By specifying this flag, the user indicates to any groupings unconfigured that data they would ordinarily preserve might be deleted.

unconfigure [–s] [– g system] –-include-site-profile
–-include-site-profile

This option is only valid with the unconfigure subcommand.

This flag will unconfigure the system and remove configuration data from the SMF site-profile and admin layers. This effectively returns the system to the original system configuration state that was delivered by the installers.

The XML profiles stored in the site-profile directory at /etc/svc/profile/site will be removed and saved as part of this process. Administrative customizations will be deleted for all groupings. All data stored in /etc/svc/profile/sysconfig will be deleted.

Because this action is extensive, the removed XML profiles will be archived in a tar file named site-profile.tar and located in the /etc/svc/profile/sysconfig directory.

This option is only valid with the system grouping. Using –g system is optional when calling this option.

configure|reconfigure [– s] [–g grouping] [–c config_profile.xml | dir] [–-destructive ]

Configure or reconfigure a grouping. The configure subcommand has access to the same options as the unconfigure subcommand. It also includes the following additional option.

–c config_profile.xml | dir

Provides a profile or a directory of profiles to apply during configuration. If a profile is applied, the configuration step occurs non-interactively. If no profile is provided, the interactive system configuration tool is used for the configuration of the grouping.

All profiles must have an .xml file extension.

If you supply a directory to –c, all profiles in that directory must be valid (correctly formed) configuration profiles.

create-profile [–o output_file [–l logfile] [–v verbosity] [–b] [–g grouping,...]

Run the SCI tool and create a system configuration profile. The default location for the profile is /system/volatile/profile/sc_profile.xml . The configuration generated is not applied to the system.

–o output_file

Replace the default profile location with output_directory for the configuration profile.

–l logfile, – -log-location=logfile

Location of the log file. The default is /var/tmp/install/sysconfig.log

–v verbosity, – -log-level=verbosity

Verbosity level, one of error, warn, info, debug, or input. These are in order of increasing verbosity, from least to most. The default is info.

–b

Black-and-white version of SCI tool.

Examples

Example 1 Unconfiguring and Shutting Down

The following command unconfigures the system and leaves it in an unconfigured state. By default, if no grouping is specified, the groupings for the whole system are unconfigured.

# sysconfig unconfigure -s
Example 2 Unconfiguring the System

The following command unconfigures the system and leaves the system unconfigured.

# sysconfig unconfigure -g system
Example 3 Reconfiguring System Using SCI Tool

The following command brings up the SCI Tool to reconfigure a system.

# sysconfig configure
Example 4 Reconfiguring Using a Profile

The following command reconfigures a system using a profile.

# sysconfig configure -c some_profile.xml
Example 5 Creating and Using a Profile

The following sequence of commands creates a profile, then uses it to reconfigure a system.

# sysconfig create-profile -o /tmp/myprofile.xml
# sysconfig configure -g system -c /tmp/myprofile.xml
Example 6 Configuring the System in a Zone

The following command configures the system in a zone.

# zlogin ZONENAME
root@ZONENAME# sysconfig configure -g system
Example 7 Interactively Configuring Functional Groupings

The following command reconfigures the network and naming services functional groupings. The SCI Tool is invoked and the groupings will be reconfigured interactively.

# sysconfig configure -g network,naming_services
Example 8 Configuring Functional Groupings Non-interactively

The following sequence of commands creates a profile for the network and naming services, then uses the profile to reconfigure the groupings non-interactively.

# sysconfig create-profile -g network,naming_services \
-o /tmp/my_sysconfig_directory/
# sysconfig configure -g network,naming_services \
-c /tmp/my_sysconfig_directory/sc_profile.xml
Example 9 Unconfigure a System and Reverting the Groupings

The following command unconfigures a system and reverts the groupings to the default installed state.

# sysconfigure unconfigure --include-site-profile

Exit Status

0

Success.

>0

Failure.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Availability
system/core-os
system/install
system/install/configuration
system/library/install
Interface Stability
Committed

See also

svcprop(1), svcadm(1M), svccfg(1M), attributes (5), attributes(5)