The intrd daemon is started at boot time to monitor the assignments between interrupts and CPUs. If intrd decides that the current assignments are imbalanced and harmful to system performance, it will generate and implement new assignments.
Any notifications will be delivered via syslogd(1M).
Because intrd dynamically monitors a system for optimal performance, it consumes a small amount of CPU time, even on an otherwise idle system. This behavior is normal.
See attributes(5) for descriptions of the following attributes:
The interrupt distribution daemon is managed by the service management facility, smf(5), under the service identifier:
A kernel tunable parameter exists that allows the system administrator some control over the frequency at which messages are issued by intrd through syslogd(1M). The bal_msg_period variable defines a 'quiet period' in seconds during which message output is suppressed. One instance of a message is output during bal_msg_period with any subsequent calls to output that message suppressed, counted and reported as a total after the period has elapsed. The default value is 1800 seconds, that is, 30 minutes, with the minimum being 10 and the maximum being 86400 seconds, that is, 24 hours. A bal_msg_period value of 0 (zero) switches off message suppression. Any change should be made using system (4).