rem_drv [-b basedir] [-C] [-n] device_driver
The rem_drv command informs the system that the device driver device_driver is no longer valid. If possible, rem_drv unloads device_driver from memory. rem_drv also updates the system driver configuration files.
If rem_drv has been executed, the next time the system is rebooted it automatically performs a reconfiguration boot (see kernel(1M)).
The following options are supported:
Sets the path to the root directory of the diskless client. Used on the server to execute rem_drv for a client. The client machine must be rebooted to unload the driver.
Remove dangling device attribute nodes bound to the driver being removed. This causes any device ownership or permissions customizations made to any node not to be preserved if the driver is added back. Recommended for use when reprovisioning a machine from one configuration or use to another where past administrative customizations might not be desired.
Do not try to detach and unload device_driver, just modify the system configuration files for that driver.
The following example removes the sd driver from use:
example% rem_drv sdExample 2 Removing a Diskless Client
The following example removes the driver from the sun1 diskless client. The driver is not uninstalled or unloaded until the client machine is rebooted.
example% rem_drv –b /export/root/sun1 sd
Note the caveat on the use of the –b option in the description of that option, above.
See attributes(5) for descriptions of the following attributes: