man pages section 1M: System Administration Commands

Exit Print View

Updated: July 2014
 
 

flowstat(1M)

Name

flowstat - report flow statistics

Synopsis

flowstat [-r | -t] [
-i interval] [-l 
link] [-T d|u] [flow] [
interval [count]]
flowstat [-S] [-A] [
-i interval] [-p] [ 
-o field[,...]]
     [-u R|K|M|G|T|P] [link] [
-l link] [-T d|u] [
flow] [interval [count]]
flowstat -h [-a] 
-f filename [-d] [
-F format] [-s 
time]
     [-e time] [flow]

Description

The flowstat command reports run time statistics about user defined flows. flowadm show-flow provides the flow name information for this command.

Options

The flowstat command has the following options and operands that are common among a number of command forms shown under “Subcommands,” below.

Sub Commands

flowstat supports the following command forms.

flowstat [–r | –t] [–l link] [–T d|u] [flow] [ interval [count]]

This form of the command iteratively examines all flows and reports statistics. The output is sorted in descending order of flow utilization. If no flow is specified, the system displays statistics for all flows.

–r

Display receive-side statistics only. Includes bytes and packets received, drops, and so forth. See examples for complete listing.

–t

Display transmit-side statistics only. Includes bytes and packets sent, drops, and so forth. See examples below.

–i interval

If specified, it denotes the interval at which output rows are refreshed. The first row of the output is the summary that shows the total numbers since the creation of the flow. The second row and beyond show the normalized (per second) statistics. If not specified, you obtain one summary since the creation of the specified flow. This option is obsolete. Interval instead (and count also if you want) must be supplied as operand at the end of the command. Also, you cannot supply interval at both option and operand. Doing so will result in error.

–l link | flow]

Display statistics for all flows on the specified link or statistics for the specified flow.

–T u|d

Specify u for a printed representation of the internal representation of time. See time(2) . Specify d for standard date format. See date(1).

flowstat [–S] [–A] [–i interval] [–p] [ –o field[,...]] [–u R|K|M|G| T|P] [–l link] [–T d|u] [flow ] [interval [count]]

This form of the command allows you to specify which statistics to display.

–A

Dump all statistics fields for this flow. Output statistics of this command are inclusive of all the statistics reported by all other flowstat commands.

{–l link} | flow

Display statistics for all flows on the specified link or for the specified flow.

–o field[,...]

Display a case-insensitive, comma-separated list of output fields to display. The field name must be one of the fields listed below, or the special value all to display all supported fields.

List of supported RX fields:

  • flow

  • rbytes

  • ipkts

  • idrops

List of TX fields:

  • flow

  • obytes

  • opkts

  • odrops

–p

Display output in a stable, machine-parseable format.

–S

Continuously display network utilization by flow in a manner similar to the way that prstat(1M) displays CPU utilization by process.

–u R|K| M|G|T|P

If used, allows choosing the unit in which to display all statistics, for example, R: Raw Numbers, K:Kilobits, M:Megabits, T:Terabits, P:Petabits. If not used, then different units, as appropriate, are used to display the statistics.

flowstat –h [–a] – f filename [–d] [–F format] [–s time] [–e time] [flow]

Show the network usage history from a stored extended accounting file. Use of this syntax requires that net accounting has been previously configured and enabled by using acctadm(1M). The default output is the summary of network usage of the existing links for the entire period when extended accounting was enabled.

–a

Display all historical network usage for the specified period when extended accounting is enabled. This includes usage information for the flows that have already been deleted.

–f filename

Specify the file from which extended accounting records of network flow usage history are read.

–d

Display the dates for which there is logging information. The date is in the format mm/dd/ yyyy.

–F format

Specify the output format of the network flow usage history information. gnuplot is the only supported format.

–s time
–e time

Specify start and stop times for data display. Time is in the format MM/DD/ YYYY,hh:mm: ss. hh uses 24-hour clock notation.

Operands

flowstat command forms have a single, optional operand.

flow

If specified, report only on the named flow. Otherwise, report on all flows. A flow has a name of the form zonename/ flowname. A flowname without a zonename modifier is understood to be in the global zone.

interval

If specified, it denotes the interval at which output rows are refreshed. The first row of the output is the summary that shows the total numbers since the creation of the flow. The second row and beyond show the normalized (per second) statistics. If not specified, you obtain one summary since the creation of the specified flow.

count

If specified, only print 'count' rows. If not specified, print indefinitely.

Examples

Example 1 Displaying Statistics

To display statistics for all the flows, enter following command. Statistics are displayed as 3-digit numbers with the appropriate unit. Default interval is one second.

# flowstat -i 1
 FLOW   IPKTS  RBYTES  IDROPS   OPKTS  OBYTES  ODROPS
flow1 528.54K 787.39M       0 179.39K  11.85M       0
flow2 742.81K   1.10G       0       0       0       0
flow3       0       0       0       0       0       0
flow1  67.73K 101.02M       0  21.04K   1.39M       0
flow2       0       0       0       0       0       0
flow3       0       0       0       0       0       0
            .       .       .       .       .       .
            .       .       .       .       .       .
            .       .       .       .       .       .
Example 2 Displaying RX-Side Statistics

The following command displays receive-side statistics

# flowstat -r
 FLOW   IPKTS  RBYTES  IDROPS
flow1   4.01M   5.98G       0
flow2 742.81K   1.10G       0
flow3       0       0       0
Example 3 Displaying TX-Side Statistics

The following command displays transmit-side statistics at a five-second interval.

# flowstat -t
 FLOW   OPKTS  OBYTES  ODROPS
flow1  24.37M   1.61G       0
flow2       0       0       0
flow3       4     216       0

Example 4 Displaying Particular Set of Statistics

The following command displays a specified set of statistics fields.

# flowstat -o FLOW,IPKTS
 FLOW   IPKTS
flow1  68.58M
flow2 742.81K
flow3       4
Example 5 Show Historical Network Usage

Flow usage statistics can be stored by using the extended accounting facility, acctadm(1M).

# acctadm -e extended -f /var/log/net.log net
# acctadm net
         Network accounting: active
    Network accounting file: /var/log/net.log
  Tracked Network resources: extended
Untracked Network resources: none

The saved historical data can be retrieved as follows:

# flowstat -h -f /var/log/net.log
LINK      DURATION  IPACKETS RBYTES      OPACKETS OBYTES      BANDWIDTH
flowtcp   100       1031     546908      0        0            43.76Kbps
flowudp   0         0        0           0        0             0.00Mbps

Display logging information for flowtcp starting at February 19, 2008 at 10:38:46 and ending on the same day at 10:40:06:

# flowstat -h -s 02/19/2008,10:39:06 -e 02/19/2008,10:40:06 \

-f /var/log/net.log flowtcp
FLOW      START       END         RBYTES   OBYTES     BANDWIDTH
flowtcp   10:39:06    10:39:26    1546     6539        3.23 Kbps
flowtcp   10:39:26    10:39:46    3586     9922        5.40 Kbps
flowtcp   10:39:46    10:40:06    240      216       182.40 bps
flowtcp   10:40:06    10:40:26    0        0           0.00 bps

Generate the same output information as above as a plotfile:

# flowstat -h -s 02/19/2008,10:39:06 -e 02/19/2008,10:40:06 \

-F gnuplot -f /var/log/net.log flowtcp
# Time tcp-flow
10:39:06 3.23
10:39:26 5.40
10:39:46 0.18
10:40:06 0.00

Exit Status

0

All actions were performed successfully.

>0

An error occurred.

Attributes

See attributes(5) for descriptions of the following attributes:

/usr/sbin

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Availability
system/core-os
Interface Stability
See below

Screen output is Uncommitted. The invocation is Committed.

See also

acctadm(1M), dladm(1M), dlstat(1M), flowadm(1M), ifconfig(1M), prstat(1M), route(1M), attributes (5), dlpi(7P)