lldpd is a system daemon that implements the Link Layer Discovery Protocol as specified in IEEE Std. 802.1AB. The daemon also manages LLDP agents on physical datalinks. Please see lldpadm(1M) for more information on administering LLDP on LLDP agents.
The lldpd daemon is controlled through the service management facility (SMF) service instance:
This means that svcadm(1M) must be used to start, stop, restart, and refresh this daemon. This daemon is enabled by default. To enable LLDP on any of the physical datalinks, this daemon should be running.
The lldpd daemon is a project private interface and has no user-accessible options.
The following properties control the behavior of LLDP protocol on each of the LLDP agents. These are private properties that are subject to change.
Indicates the time interval between the transmission of two consecutive LLDPDUs during normal transmission periods. The default value is 30 seconds and the possible values for this property is 1 through 3600.
Indicates the time interval between the transmission of two consecutive LLDPDUs during fast transmission periods. The default value is 1 second and the possible values for this property is 1 through 3600.
The value of the TTL in the LLDPDU transmitted by the LLDP agent is determined by multiplying msgTxHold by msgTxInterval. So, if this value is set to 2, then the adjacent stations would wait for twice the msgTxInterval before aging the entries from this station. The default value is 4 and the possible values for this property is 1 through 100.
Indicates the delay before reinitialization of LLDP state machines. The default value is 2 seconds and the possible values for this property is 1 through 100.
The maximum number of consecutive LLDPDUs that can be transmitted at any time. The default value is 5 and the possible values for this property is 1 through 10.
Indicates the number of LLDPDUs that are transmitted during a fast transmission period. The default value is 4 and the possible values for this property is 1 through 8.
This boolean property turns SNMP support on or off.
Whenever any of the above properties are modified, svcadm(1M) must be used to refresh the daemon. On refresh, the daemon rereads these service properties and applies the new values. Note that none of the LLDP agents are restarted on refresh. The only action is that the configuration is reread.
The following property controls whether LLDP agents should be automatically enabled on all physical ports on system.
If LLDP is not enabled on any port on the system, enable LLDP on all ports into both mode. If LLDP is explicitly enabled in rxonly mode, or in txonly mode, or in both mode on a port, do not automatically enable LLDP on such port. This option is particularly useful when one wants to deploy LLDP in a large datacenter environment.
Regardless of whether LLDP agent is enabled on ports in rxonly mode or txonly mode or disabled, enable LLDP agents on all ports into the both mode.
Do not automatically enable LLDP agents on any port. This option does not mean that it will disable LLDP agents on all ports. Rather with this value, LLDP is required to be explicitly enabled on the desired ports. Please see lldpadm(1M) on how to enable LLDP agent explicitly.
The auto-enable-agents property is set to yes by default, which makes LLDP automatically enabled in both mode on all physical ports on the system. Whenever this property gets modified, svcadm(1M) must be used to restart the daemon. Only refresh of the daemon will not cause the restart of LLDP agents.
The following command enables the lldpd daemon.
# svcadm enable network/lldp # svcs network/lldp STATE STIME FMRI online Jan_26 svc:/network/lldp:defaultExample 2 Disabling the Daemon
The following command disables the lldpd daemon.
# svcadm disable network/lldp # svcs network/lldp STATE STIME FMRI disabled 5:11:35 svc:/network/lldp:defaultExample 3 Listing All Service Properties
The following command lists all service properties.
# svcprop -p lldp network/lldp:default lldp/msgFastTx count 1 lldp/msgTxHold count 4 lldp/reinitDelay count 2 lldp/snmp boolean false lldp/stability astring Evolving lldp/txCreditMax count 5 lldp/txFastInit count 4 lldp/msgTxInterval count 30Example 4 Modifying the Service Property, Refreshing the Daemon
The following command sequence changes the LLDPDU transmission interval to every 15 seconds.
# svccfg -s lldp:default setprop lldp/msgTxInterval = 15 # svcadm refresh lldp:default # svcprop -p lldp/msgTxInterval lldp:default 15Example 5 Modifying auto-enable-agents, Restarting Daemon
The following command sequence modifies the auto-enable-agents property and restarts the LLDP daemon.
# svccfg -s lldp:default setprop lldp/auto-enable-agents = no # svcadm restart lldp:default
See attributes(5) for descriptions of the following attributes:
IEEE Std 802.1AB-2009, IEEE Standard for Local and Metropolitan Area Networks: Station and Media Access Control Connectivity Discovery