man pages section 1M: System Administration Commands

Exit Print View

Updated: July 2014
 
 

mount_uvfs (1M)

Name

mount_uvfs - mount a UVFS file system

Synopsis

mount [-F uvfs] [generic_options] [-o specific_options] [-O] resource
mount [-F uvfs] [generic_options] [-o specific_options] [-O] mount_point
mount [-F uvfs] [generic_options] [-o specific_options]
          [-O] resource mount_point

Description

The mount utility attaches a named resource to the file system hierarchy at the pathname location mount_point, which must already exist. If mount_point has any contents prior to the mount operation, the contents remain hidden until the resource is once again unmounted.

UVFS is a pseudo file system that sends file system requests, such as read and write system calls to a user-level file system daemon. These requests are routed to the daemon by using libuvfs.

Oracle Solaris provides an implementation of libfuse that is layered upon libuvfs and supports the FUSE API so that you can mount open source file systems.

An example of a user-level file system is one written to the libfuse API, such as the Oracle database file system (DBFS).

Options

See mount(1M) for the list of supported generic options.

You might consider using the following file system specific options by using the –o option with a comma-separated list and no intervening spaces.

–o specific_options
allow_other | noallow_other

By default, Oracle's DBFS file system does not allow access by other users. If the allow_other option is specified, users are granted standard UNIX permissions.

forcedirectio | noforcedirectio

If the file system is mounted using forcedirectio, data is transferred directly between the client and server, with no buffering on the client. If the file system is mounted using noforcedirectio, data is buffered on the client. Mounting a file system with forcedirectio might benefit the performance of large sequential data transfers. The default behavior is noforcedirectio.

intr | nointr

Allows or disallows keyboard interrupts to kill a process that is hung while waiting for a response from the driver. The default is intr, which makes it possible for clients to interrupt applications that can be waiting for a driver.

max_dthreads

Sets the maximum number of threads to be run in the daemon that is used for servicing calls. The default value is 16.

max_read
max_write

Sets the maximum number of bytes that are passed to or from the daemon for writes and reads, not counting the overhead of asking for the write or read.

mnt_timeout

If the value specified in mnt_timeout is greater than the default timeout (30s), then the specified value will be used. Otherwise, the default value will be used.

Examples

Example 1 Mounting a DBFS File System

You can mount a DBFS file system, but you will need to provide a small shell script that sets up the DBFS environment, such as setting a password, and so on. See the example below.

# mount -F uvfs /script-path /mount-point

Sample shell script to set up DBFS envrionment:

#! /bin/sh

export ORACLE_HOME=/dbfs_path
export ORACLE_TNS_ADMIN=/dir

exec dbfs_client user@instance <<EOF
password
EOF

Files

/etc/mnttab

Table of mounted file systems

See also

mount(1M), mountall(1M), mount (2) , stat (2) , time (2) , mnttab (4) , vfstab (4) , attributes (5) , environ (5) , uvfs (7FS)