/usr/sbin/devfsadm [-C] [-c device_class] [-i driver_name] [ -n] [-r root_dir] [-s] [-t table_file] [-u] [-v]
The default operation is to attempt to load every driver in the system and attach to all possible device instances. Next, devfsadm creates logical links to device nodes in /dev and /devices and loads the device policy.
devfsadmd(1M) is the daemon version of devfsadm(1M). The daemon is started during system startup and is responsible for handling both reconfiguration boot processing and updating /dev and /devices in response to dynamic reconfiguration event notifications from the kernel.
For compatibility purposes, drvconfig(1M), disks(1M), tapes(1M) , ports(1M), audlinks(1M), and devlinks(1M) are implemented as links to devfsadm.
In addition to managing /dev, devfsadm also maintains the path_to_inst(4) database.
The following options are supported:
Cleanup mode. Prompt devfsadm to cleanup dangling /dev links that are not normally removed. If the –c option is also used, devfsadm only cleans up for the listed devices' classes.
Restrict operations to devices of class device_class. Solaris defines the following values for device_class: disk, tape, port, audio, and pseudo. This option might be specified more than once to specify multiple device classes.
Configure only the devices for the named driver, driver_name.
Do not attempt to load drivers or add new nodes to the kernel device tree.
Suppress any changes to /dev. This is useful with the –v option for debugging.
Read an alternate devlink.tab file. devfsadm normally reads /etc/devlink.tab.
Activate and attach devices for drivers added with add_drv(1M) –u. Cannot be used together with –n or –r.
Presume that the /dev directory trees are found under root_dir, not directly under root (/). No other use or assumptions are made about root_dir.
Print changes to /dev in verbose mode.
The following exit values are returned:
An error occurred.
device nodes directory
logical symbolic links to /devices
update lock file
daemon lock file
device policy file
additional device privileges
See attributes(5) for descriptions of the following attributes:
This document does not constitute an API. The /devices directory might not exist or might have different contents or interpretations in a future release. The existence of this notice does not imply that any other documentation that lacks this notice constitutes an API.
devfsadm no longer manages the /devices name space. See devfs(7FS).
As a daemon to support hot-plug and synchronous device naming, devfsadm is managed by the service management facility, smf(5), under the service identifier:
The status of the service can be queried using the svcs(1) command.