hal-device [-h] [--a udi | --r udi]
The Hardware Abstraction Layer (HAL) provides a view of the various hardware attached to a system. The hal-device command enables you to manage devices that conform to the HAL standard. Specifically, hal-device lets you add or remove a device to or from the HAL global device list. Device properties are read from stdin in lshal(1M) syntax.
The following options are supported:
Add device specified by Universal Device Identifier udi to HAL's global device list.
Display usage information.
Remove device specified by Universal Device Identifier udi from HAL's global device list.
See attributes(5) for descriptions of the following attributes: