|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Express 11/10|
- handle metadevice resync during reboot
/usr/sbin/metasync [-s setname] [buffer_size] metadevice
/usr/sbin/metasync [-s setname] -r [buffer_size]
/usr/sbin/metasync -p metadevice
/usr/sbin/metasync -c metadevice
The metasync command starts a resync operation on the specified metadevice. All components that need to be resynced are resynced. If the system crashes during a RAID5 initialization, or during a RAID5 resync, either an initialization or resync restarts when the system reboots.
Applications are free to access a metadevice at the same time that it is being resynced by metasync. Also, metasync performs the copy operations from inside the kernel, which makes the utility more efficient.
Use the -r option in boot scripts to resync all possible submirrors.
The following options are supported:
Cancels the resync that is in progress on the specified metadevice. The resync will be stopped at its current point and can be resumed by running the “metasync metadevice” command. This option only applies to RAID1 volumes.
Displays usage message.
Regenerates parity information for RAID5 metadevices.
Specifies the name of the diskset on which metasync will work. Using the -s option will cause the command to perform its administrative function within the specified diskset. Without this option, the command will perform its function on local metadevices.
Specifies that the metasync command handle special resync requirements during a system reboot. metasync -r should only be invoked from the svc:/system/mdmonitor service. The metasync command only resyncs those metadevices that need to be resynced. metasync schedules all the mirror resyncs according to their pass numbers.
To override the default buffer_size value used by the svc:/system/mdmonitor service, you can edit /etc/system to specify:
set md_mirror:md_resync_bufsz = 2048
so that resyncs occur as quickly as possible.
Specifies the size (number of 512-byte disk blocks) of the internal copy buffer for the mirror resync. The size defaults to 1024 512-byte disk blocks. It can be no more than 2048 blocks. For best performance (quickest completion of the resync), 2048 blocks is the recommended size.
The following exit values are returned:
An error occurred.
See attributes(5) for descriptions of the following attributes:
mdmonitord(1M), metaclear(1M), metadb(1M), metadetach(1M), metahs(1M), metainit(1M), metaoffline(1M), metaonline(1M), metaparam(1M), metarecover(1M), metarename(1M), metareplace(1M), metaroot(1M), metaset(1M), metassist(1M), metastat(1M), metattach(1M), md.tab(4), md.cf(4), mddb.cf(4), md.tab(4), attributes(5), md(7D)
The metasync service is managed by the service management facility, smf(5), under the service identifier: