|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Express 11/10|
- system configuration
sysidtool is a suite of programs that configure a new system, or one that has been unconfigured with sys-unconfig(1M). The sysidtool programs run automatically at system installation, or during the first boot after a machine has been successfully unconfigured.
These programs have no effect except at such times, and should never be run manually.
The sysidtool programs set up the appropriate information in the machine's configuration files, in the kernel, and on the machine's network interface. The following list shows the available commands and the information for which each of the commands lists.
Machine's default locale. Machine's console type. Machine's host name. Machine's IP address.
Name service choice: NIS, DNS, LDAP, or none. Machine's IP subnet mask (if no NIS server can automatically be located on the machine's sub-network. Domain name for chosen name service. Hostname and IP address of name server(s). DNS search list (DNS name service only)
Machine's IP subnet mask (if an NIS server was automatically located on the machine's sub-network). Machine's time zone. Date and time.
Machine's root password.
Auto-shutdown confirmation if the system is Energystar-V2 compliant, that is, a new system model shipped after October 1, 1995.
Domain name to be used by NFSv4 client(s) and server(s) to transmit user and group id's as strings of the general form “[user|group]@domain”.
The corresponding keytable is loaded into the kernel according to the configured keyboard layout.
This command controls specification and execution of custom configuration applications that can be specified for a particular host or a particular platform. See sysidconfig(1M).
The sysidtool programs attempt to obtain system configuration information from various name service databases, for example, NIS, or from the sysidcfg(4) file, and you are prompted to provide the information if it cannot be found. However, you can avoid one or more of the prompts by preconfiguring the appropriate configuration information in the name service databases or in the sysidcfg(4) file.
To preconfigure the information in the name service databases, you must use the name service commands or the Solstice AdminSuite tools. See for more details about how to preconfigure the system configuration information.
The machine's configuration information is set up in its /etc and /var files.
If a system has more than one network interface, you can use sysidtool to configure all interfaces on the system.
You cannot use the name service databases or the sysidcfg(4) file to suppress the Power Management configuration prompt. However, you can suppress it by creating either the /autoshutdown or /noautoshutdown file before installation reboot. Accordingly, the auto-shutdown feature is silently configured. The /autoshutdown or /noautoshutdown files are removed by sysidpm before it exits.
If you have non-global zones installed and the nfs4_domain keyword exists in the sysidcfg file, the first boot of a non-global zone sets the domain. Otherwise, the Solaris interactive installation program comes up and you are prompted to provide a domain name before the boot process completes. See sysidcfg(4) and Solaris Express Installation Guide: Custom JumpStart and Advanced Installations.
sysidkbd prompts for the keyboards with zero-bCountryCode and then sets the keyboard layout string in the /etc/default/kbd file. If the sysidkbd gets the valid keyboard layout string, the string will be set into the entry “LAYOUT=” in the file.
Power Management configuration file. See power.conf(4).
If this file is present during system reboot, the sysidpm program is run. This file is removed by sysidpm.
See attributes(5) for descriptions of the following attributes: