|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Express 11/10|
- fbconfig module for configuring XVR-300 Graphics Accelerator
fbconfig [-dev device-filename] [-res video-mode [now | try] [noconfirm | nocheck]] [-file machine | system] [-fake8 enable | disable] [-doublewide enable | disable] [-doublehigh enable | disable] [-clone enable | disable] [-outputs swapped | direct] [-depth 8 | 24] [-offset xval yval] [-defaults]
fbconfig [-propt] [-prconf]
fbconfig [-help] [-res ?]
SUNWnfb_config is the XVR-300 device dependent layer for fbconfig. It configures the XVR-300 Graphics Accelerator and some of the X11 window system defaults for XVR-300. The XVR-300 provides the capability to drive two monitors, each with a unique video stream (Stream #1 and Stream #2).
The first form of SUNWnfb_config shown in the SYNOPSIS section sets options for the XVR-300. This form stores the specified options in the OWconfig file. These options will be used to initialize the XVR-300 device the next time the window system is run on that device. Updating options in the OWconfig file provides persistence of these options across window system sessions and system reboots. For -res now, the XVR-300 device will be immediately programmed.
The second form, which invokes the -prconf and -propt options, queries the XVR-300 for status.
The third form, which invokes the -help and -res ? options, provides instruction on using SUNWnfb_config. Additionally, for the third form all other options are ignored.
Options may be specified for only one XVR-300 device at a time. Specifying options for multiple XVR-300 devices requires multiple invocations of SUNWnfb_config.
Only XVR-300-specific options can be specified through SUNWnfb_config. The normal window system options for specifying default depth, default visual class and so forth can still be specified as device modifiers on the command line when the X Server is started. See the dtlogin(1) reference to Xservers File.
The user can also specify the OWconfig file that is to be updated. By default, the machine-specific file in the /etc/openwin directory tree is updated. The -file option can be used to specify an alternate file to use. For example, the system-global OWconfig file in the /usr/openwin directory tree can be updated instead.
Specifies the XVR-300 special file. The default is /dev/fb.
Specifies which OWconfig file to update. If machine, the machine-specific OWconfig file in the /etc/openwin directory tree is used. If system, the global OWconfig file in the /usr/openwin directory tree is used. If the file does not exist, it is created.
Specifies the video mode used to drive the monitor connected to the specified XVR-300 device. Video modes are built-in.
Specifies resolution and timing information for the display (for example, 1280x1024x76). The format of the video-mode specifier is: widthxheightxrate. width is the screen width in pixels, height is the screen height in pixels, and rate is the vertical frequency of the screen refresh. As a convenience, -res also accepts formats with @ preceding the refresh rate instead of x. For example, 1280x1024@76.
Symbolic names. For convenience, some video modes have symbolic names defined for them. Instead of the form widthxheightxrate, one of these names may be supplied as the argument to -res. The meaning of the symbolic name none is that when the window system is run, the screen resolution will be the video mode that is currently programmed in the device.
Some video-modes supported by XVR-300 may not be supported by the monitor. The list of video-modes supported by the XVR-300 device and the monitor can be obtained by running SUNWnfb_config with the -res ? option (the third form shown in the command SYNOPSIS section).
-res option arguments. The -res option also accepts additional, optional arguments immediately following the video mode specification. Any or all of these may be present.
If present, not only will the video mode be updated in the OWconfig file, but the XVR-300 device will be immediately programmed to display this video mode. (This is useful for changing the video mode before starting the window system).
It is inadvisable to use this suboption with SUNWnfb_config while the configured device is being used (for example, while running the window system) because unpredictable results may occur. To run SUNWnfb_config with the now suboption, first bring the window system down. If the now suboption is used within a window system session, the video mode will be changed immediately, but the width and height of the affected screen won't change until the window system is exited and reentered again. Consequently, this usage is discouraged.
Using the -res option, the user could put the system into an unusable state, which has no video output. To reduce the chance of this, the default behavior of SUNWnfb_config is to print a warning message and to ask the user whether to continue. The noconfirm suboption bypasses this confirmation. This suboption is useful when SUNWnfb_config is being run from a shell script.
If present, the normal error checking based on the monitor sense code will be suspended. The video mode specified by the user will be accepted regardless of whether it is appropriate for the currently attached monitor. This suboption is useful if a different monitor is to be connected to the XVR-300 device. Use of this suboption implies noconfirm as well.
If present, the specified video mode will be programmed on a trial basis. The user will be asked to confirm the video mode by typing 'y' within 10 seconds. Or the user may terminate the trial before 10 seconds are up by typing any character. Any character other than 'y' or carriage return is considered a no and the previous video mode will be restored and SUNWnfb_config will not change the video mode in the OWconfig file (other options specified will still take effect). If a carriage return is typed, the user is prompted for a yes or no answer on whether to keep the new video mode. This option implies the now suboption (see the warning note on the now suboption).
This option allows you to configure the two outputs of the Sun XVR-300 into one horizontal virtual display. Both video outputs will be set to the same resolution. Default is disable.
This option allows you to configure the two outputs of the Sun XVR-300 into one vertical virtual display. Both video outputs will be set to the same resolution. Default is disable.
If this option is set to enable, the two outputs will display identically. Default is disable.
If either doublewide or doublehigh is enabled, this option allows you to reverse the positions of the two outputs relative to each other. Default is direct.
If enabled, simple 8 bit X windows will be rendered without a hardware colormap to reduce colormap flashing. Some performance reductions may be observed. Default is disable.
Sets the default depth for the window system to start with. Possible values are 8 or 24. Log out of the current window system session and log back in for the change to take effect. Any defdepth setting in the Xserver command line takes precedence over what is set using fbconfig. Default is 24. This option is only supported on Solaris 9. For Solaris 10 and above, use /usr/sbin/svccfg to configure depth.
Adjusts the position of the specified stream by the value specified. Currently only implemented in -doublewide and -doublehigh modes. For -doublewide, the xval is used to position the rightmost stream. Negative is left (overlaps with the left stream). For -doublehigh, the yval is used to position the bottom stream. Negative is up (overlaps with top stream). Positive values are treated as 0. Default is [0, 0]
Resets all option values to their default values.
Prints the current values of all XVR-300 options in the OWconfig file specified by the -file option for the device specified by the -dev option. Prints the values of options as they will be in the OWconfig file after the call to SUNWnfb_config completes. This is a typical display:
--- Graphics Configuration for /dev/fbs/nfb0 --- OWconfig: machine Video Mode: NONE Screen Information: Doublewide: Disable Doublehigh: Disable Clone: Disable Offset/Overlap: [0, 0] Output Configuration: Direct Fake8 Rendering: Disable
Prints the XVR-300 hardware configuration. This is a typical display:
--- Hardware Configuration for /dev/fbs/nfb0 --- Type: XVR-300 ASIC: version 0x5b64 REV : version 0x3800080 PROM: version 1.6 Monitor/Resolution Information: Monitor 1: Monitor Manufacturer: SUN Product code: 1383 Serial #: 18499659 Manufacture date: 1999, week 36 Monitor dimensions: 39x29 cm Monitor preferred resolution: SUNW_STD_1280x1024x76 Separate sync supported: yes Composite sync supported: yes EDID: Version 1, Revision 1 Monitor Supported resolutions from EDID: SUNW_STD_1280x1024x76, SUNW_STD_1152x900x76, 1600x1200x75, SUNW_STD_1280x1024x76, SUNW_STD_1152x900x76, VESA_STD_1280x1024x75, SUNW_STD_1280x1024x67, SUNW_STD_1152x900x66, VESA_STD_1024x768x75, SUNW_STD_1600x1200x75, 960x720x112, VESA_STD_720x400x70, VESA_STD_720x400x88, VESA_STD_640x480x60, VESA_STD_640x480x67, VESA_STD_640x480x72, VESA_STD_640x480x75, VESA_STD_800x600x56, VESA_STD_800x600x60, VESA_STD_800x600x72, VESA_STD_800x600x75, VESA_STD_832x624x75, VESA_STD_1024x768x60, VESA_STD_1024x768x70, VESA_STD_1024x768x75, VESA_STD_1280x1024x75, APPLE_1152x870x75 Current resolution setting: 1280x1024x76 Monitor 2: Monitor Manufacturer: SUN Product code: 1352 Serial #: 7225675 Manufacture date: 1997, week 51 Monitor dimensions: 48x31 cm Monitor preferred resolution: 1920x1200x70 Separate sync supported: yes Composite sync supported: yes EDID: Version 1, Revision 1 Monitor Supported resolutions from EDID: 1920x1200x70, SUNW_STD_1600x1000x76, SUNW_STD_1600x1000x66, SUNW_STD_1440x900x76, 1920x1080x70, 1600x900x76, 1600x900x66, 1440x810x76, 1280x720x76, 1920x1080x72, VESA_STD_720x400x70, VESA_STD_720x400x88, VESA_STD_640x480x60, VESA_STD_640x480x67, VESA_STD_640x480x72, VESA_STD_640x480x75, VESA_STD_800x600x56, VESA_STD_800x600x60, VESA_STD_800x600x72, VESA_STD_800x600x75, VESA_STD_832x624x75, VESA_STD_1024x768x60, VESA_STD_1024x768x70, VESA_STD_1024x768x75, VESA_STD_1280x1024x75, APPLE_1152x870x75 Current resolution setting: 1152x900x66
Prints a list of the SUNWnfb_config command line options, along with a brief explanation of each.
Prints list of defined video-mode names.
For a given invocation of a SUNWnfb_config command line if an option does not appear on the command line, the corresponding OWconfig option is not updated and retains its previous value.
When the window system is run, if an XVR-300 option has never been specified via SUNWnfb_config, a default value is used. The option defaults are as follows:
The default for the -res option of none means that when the window system is run, the screen resolution will be the video mode that is currently programmed in the XVR-300 PROM.
This provides compatibility for users who are used to specifying the device resolution through the XVR-300 PROM. On some devices (for example, GX) this is the only way of specifying the video mode. This means that the PROM ultimately determines the default XVR-300 video mode.
Example 1 Switching the monitor type
The following example switches the monitor type to the resolution of 1280 × 1024 at 76 Hz:
example% fbconfig -res 1280x1024x76
Device special file for XVR-300 single screen
Device special file for the XVR-300 first video out
Device special file for the XVR-300 second video out
Device dependent configuration module
See attributes(5) for descriptions of the following attributes:
See the dtlogin(1) man page in the CDE man page collection. Also useful is the XSun(1) man page in the OpenWindows man page collection.