|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Express 11/10|
- administer FTP Server enhanced group access file
privatepw [-c] [-f ftpgroups] [-g real_group_name] accessgroup
privatepw -d [-f ftpgroups] accessgroup
privatepw -l [-f ftpgroups]
The privatepw utility is an administrative tool to add, delete and list enhanced access group information in the ftpgroups file. See ftpgroups(4).
When privatepw is used without options, the help usage message is displayed. The privatepw utility prompts for a password when adding an enhanced access group entry or modifiying an existing one.
The following options are supported by the privatepw utility:
Create a new ftpgroups file for the specified accessgroup.
Delete information about the specified accessgroup from the ftpgroups file.
Use the specifed ftpgroups file for all updates.
Set the real system group to the group specified. group is a valid group name returned by getgrnam(3C). If the real system group is not supplied with the -g option when adding an ehanced access group entry, the privatepw utility prompts for it.
List the contents of the ftpgroups file.
Display program copyright and version information, then terminate.
The following operands are supported:
The name of the enhanced access group to create or update It consists of an arbitrary string of alphanumeric and punctuation characters. See ftpgroups(4).
The following exit values are returned:
An error occurred.
See attributes(5) for descriptions of the following attributes: