|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Express 11/10|
- configure the M64 Graphics Accelerator
/usr/sbin/m64config [-defaults] [-depth 8 | 24 | 32] [-dev device-filename] [-file machine | system] [-prconf] [-propt] [-res video-mode [now | try] [noconfirm | nocheck ]]
/usr/sbin/m64config [-prconf] [-propt]
/usr/sbin/m64config [-help] [-res ?]
m64config configures the M64 Graphics Accelerator and some of the X11 window system defaults for M64.
The first form of m64config stores the specified options in the OWconfig file. These options will be used to initialize the M64 device the next time the window system is run on that device. Updating options in the OWconfig file provides persistence of these options across window system sessions and system reboots.
The second and third forms which invoke only the -prconf, -propt, -help, and -res ? options do not update the OWconfig file. Additionally, for the third form all other options are ignored.
Options may be specified for only one M64 device at a time. Specifying options for multiple M64 devices requires multiple invocations of m64config.
Only M64-specific options can be specified through m64config. The normal window system options for specifying default depth, default visual class and so forth are still specified as device modifiers on the openwin command line. See the OpenWindows Desktop Reference Manual for details.
The user can also specify the OWconfig file that is to be updated. By default, the machine-specific file in the /etc/openwin directory tree is updated. The -file option can be used to specify an alternate file to use. For example, the system-global OWconfig file in the /usr/openwin directory tree can be updated instead.
Both of these standard OWconfig files can only be written by root. Consequently, the m64config program, which is owned by the root user, always runs with setuid root permission.
Resets all option values to their default values.
Sets the depth (bits per pixel) on the device. Possible values are 8, 24, or 32 (where 32 uses 24 bits per pixel). Log out of the current window system session and log back in for the change to take effect. 24 or 32 enables TrueColor graphics in the window system, at the expense of screen resolution.
The 32 setting enables simultaneous 8– and 24–bit color windows on m64 devices that support it. With setting 32, -propt shows depth 32 and -prconf shows depth 24. To check window depth, use the xwininfo utility. The xwininfo utility is usually shipped in the package containing frame buffer software (such as SUNWxwplt).
The maximum resolution that is available with 24 bits per pixel depends on the amount of memory installed on the PGX card. For 2-MB PGX cards, the maximum available resolution is 800x600. For 4-MB cards, it is 1152x900. For 8-MB cards, it is 1920x1080. If there is not enough memory for the specified combination of resolution and depth, m64config displays an error message and exits.
Specifies the M64 special file. If not specified, m64config will try /dev/fbs/m640 through /dev/fbs/m648 until one is found.
Specifies which OWconfig file to update. If machine, the machine-specific OWconfig file in the /etc/openwin directory tree is used. If system, the global OWconfig file in the /usr/openwin directory tree is used. If the file does not exist, it is created. This option has no effect unless other options are specified. The default is machine.
Prints a list of the m64config command line options, along with a brief explanation of each.
Prints the M64 hardware configuration. The following is a typical display using the -prconf option:
--- Hardware Configuration for /dev/fbs/m640 --- ASIC: version 0x41004754 DAC: version 0x0 PROM: version 0x0 Card possible resolutions: 640x480x60, 800x600x75, 1024x768x60 1024x768x70, 1024x768x75, 1280x1024x75, 1280x1024x76 1280x1024x60, 1152x900x66, 1152x900x76, 1280x1024x67 960x680x112S, 960x680x108S, 640x480x60i, 768x575x50i 1280x800x76, 1440x900x76, 1600x1000x66, 1600x1000x76 vga, svga, 1152, 1280, stereo, ntsc, pal Monitor possible resolutions: 720x400x70, 720x400x85, 640x480x60 640x480x67, 640x480x72, 640x480x75, 800x600x56, 800x600x60 800x600x72, 800x600x75, 832x624x75, 1024x768x85, 1024x768x60 1024x768x70, 1024x768x75, 1280x1024x75, 1280x1024x76, 1152x900x66, 1152x900x76, 1280x1024x67, 960x680x112S vga, svga, 1152, 1280, stereo Possible depths: 8, 24 Current resolution setting: 1280x1024x76 Current depth: 8
Prints the current values of all M64 options in the OWconfig file specified by the -file option for the device specified by the -dev option. Prints the values of options as they will be in the OWconfig file after the call to m64config completes. The following is a typical display using the -propt option:
--- OpenWindows Configuration for /dev/fbs/m640 --- OWconfig: machine Video Mode: not set Depth: 8
Specifies the video mode used to drive the monitor connected to the specified M64 device. Video modes are built-in. video-mode has the format of widthxheightxrate. width is the screen width in pixels, height is the screen height in pixels, and rate is the vertical frequency of the screen refresh. As a convenience, -res also accepts formats with @ preceding the refresh rate instead of x. For example, 1280x1024@76.
A list of valid video modes is obtained by issuing the following command: m64config -res '?'. Note that the ? must be quoted. Not all resolutions are supported by both the video board and by the monitor. m64config will not permit you to set a resolution the board does not support, and will request confirmation before setting a resolution the monitor does not support.
For convenience, some video modes have symbolic names defined for them. Instead of the form widthxheightxrate, one of these names may be supplied as the argument to -res. The meaning of the symbolic name none is that when the window system is run the screen resolution will be the video mode that is currently programmed in the device.
The -res option also accepts additional sub-options immediately following the video mode specification. Any or all of these may be present.
If present, the normal error checking based on the monitor sense code will be suspended. The video mode specified by the user will be accepted regardless of whether it is appropriate for the currently attached monitor. This option is useful if a different monitor is to be connected to the M64 device. Use of this option implies noconfirm as well.
Using the -res option, the user could potentially put the system into an unusable state, a state where there is no video output. This can happen if there is ambiguity in the monitor sense codes for the particular code read. To reduce the chance of this, the default behavior of m64config is to print a warning message to this effect and to prompt the user to find out if it is okay to continue. The noconfirm option instructs m64config to bypass this confirmation and to program the requested video mode anyway. This option is useful when m64config is being run from a shell script.
If present, not only will the video mode be updated in the OWconfig file, but the M64 device will be immediately programmed to display this video mode. (This is useful for changing the video mode before starting the window system).
It is inadvisable to use this sub-option with m64config while the configured device is being used (for example, while running the window system); unpredictable results may occur. To run m64config with the now sub-option, first bring the window system down. If the now sub-option is used within a window system session, the video mode will be changed immediately, but the width and height of the affected screen won't change until the window system is exited and reentered again. Consequently, this usage is strongly discouraged.
If present, the specified video mode will be programmed on a trial basis. The user will be asked to confirm the video mode by typing y within 10 seconds. Or the user may terminate the trial before 10 seconds are up by typing any character. Any character other than 'y' or carriage return is considered a no and the previous video mode will be restored and m64config will not change the video mode in the OWconfig file (other options specified will still take effect). If a carriage return is typed, the user is prompted for a yes or no answer on whether to keep the new video mode.
This sub-option should not be used with m64config while the configured device is being used (for example, while running the window system) as unpredictable results may occur. To run m64config with the try sub-option, the window system should be brought down first.
For a given invocation of m64config command line if an option does not appear on the command line, the corresponding OWconfig option is not updated; it retains its previous value.
When the window system is run, if an M64 option has never been specified by m64config, a default value is used. The option defaults are as follows:
The default for the -res option of none means that when the window system is run the screen resolution will be the video mode that is currently programmed in the device.
This provides compatibility for users who are used to specifying the device resolution through the PROM. On some devices (for example, GX) this is the only way of specifying the video mode. This means that the PROM ultimately determines the default M64 video mode.
Example 1 Switching the Monitor Type
The following example switches the monitor type to the maximum resolution of 1280 x 1024 at 76 Hz:
example% /usr/sbin/m64config -res 1280x1024x76
device special file
system config file (creates or updates the file)
symbolic link to usr/sbin/m64config
See attributes(5) for descriptions of the following attributes: