|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Express 11/10|
- execute system configuration applications, or define set of system configuration applications
sysidconfig [-lv] [-a application] [-b basedir] [-r application]
Invoked without any options, the sysidconfig program executes a list of applications. An application on this list is referred to as a “system configuration application.” Every application on this list will be passed one command-line argument, -c. This flag will cause the system configuration application to perform its configuration function. Without options, sysidconfig should only be invoked by startup scripts, which occurs during the initial installation and during a reconfigure reboot.
All applications on the list will be executed, if possible. All activity taken by the sysidconfig program is logged in the sysidconfig log file, /var/log/sysidconfig.log. If one or more of the applications on the list are either not present at execution time, are not executable, or execute but return a failure code upon completion, then that information will be logged as well. Successful completion of the program can be assumed if no error message is present in the log file. Programs are executed sequentially, with only one configuration application active at a time.
Executed with the -l, -a, or -r options, the sysidconfig program allows the super-user to list the defined configuration applications, and to add items to or remove items from that list. Running sysidconfig with options is the only way to view or manipulate the list. Only the super-user can execute the sysidconfig program with options.
The -b and -v options change the behavior of sysidconfig, and can be used with or without the list manipulation options discussed above. The -b basedir option is used to specify a reference root directory other than the default, /. The -v option duplicates the log file output on stdout.
By default, no SPARC based applications exist on this list.
This application is an extension of the sysidtool(1M) suite of programs. It is executed during initial installation and during a reconfigure reboot, before the window system has been started. Graphical User Interface (GUI) applications will not execute successfully if they are added to the list of configuration applications via sysidconfig -a.
This program is referenced, but not fully described, in the sysidtool(1M) manual page.
The valid options are:
Add the named application to the list of defined applications. When next invoked without arguments, sysidconfig will run this newly added application after all previously defined applications. application must be a fully qualified path name that is not currently on the list of applications to execute.
Specify an alternate base directory (/ is defined as the default base directory if no other is specified). The specified directory is used as the root directory when adding, listing, removing, or executing configuration applications. The log file where information is recorded is in /var/log, relative to the specified basedir. In the log file, the basedir is not noted. This means, for example, that if the super-user on a diskless client's server executes:
sysidconfig -b /export/root/client -a /sbin/someapp
then the diskless client client would have /sbin/someapp executed upon reconfigure reboot. The diskless client's log file would note that /sbin/someapp was added, not /export/root/client/sbin/someapp.
Note - The root file system of any non-global zones must not be referenced with the -b option. Doing so might damage the global zone's file system, might compromise the security of the global zone, and might damage the non-global zone's file system. See zones(5).
List defined configuration applications. Applications will be executed one at a time, in the order shown in the list.
Remove the named application from the list of defined applications. application must be a fully qualified path name and it must be on the existing list of applications to execute.
Verbose mode. This option echoes all information sent to the log file to stdout. Such information includes timestamp information about when the program was executed, the names of applications being executed, and results of those executions.
The sysidconfig program will return 0 if it completes successfully.
When executed with the -r or -a options, error conditions or warnings will be reported on stderr. If the requested action completes successfully, an exit code of 0 will be returned.
The program was executed by a user other than the super-user.
Option -l, -a, or -r was passed and the action could not be completed successfully.
sysidconfig log file
See attributes(5) for descriptions of the following attributes:
When run without options, a log of the sysidconfig program's activity can be found in /var/log/sysidconfig.log. This file contains a timestamp log of each program executed, its resulting stderr output, and its exit code. If an application in the list was not found or is not executable, that will also be noted.