|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Express 11/10|
- display or modify global state of system resource controls
rctladm [-lu] [-e action] [-d action] [name...]
The rctladm command allows the examination and modification of active resource controls on the running system. An instance of a resource control is referred to as an rctl. See setrctl(2) for a description of an rctl; see resource_controls(5) for a list of the rctls supported in the current release of the Solaris operating system. Logging of rctl violations can be activated or deactivated system-wide and active rctls (and their state) can be listed.
An rctladm command without options is the equivalent of an rctladm with the -l option. See the description of -l below.
The following options are supported:
Disable (-d) or enable (-e) the global action on the specified rctls. If no rctl is specified, no action is taken and an error status is returned. You can use the special token all with the disable option to deactivate all global actions on a resource control.
You can set the syslog action to a specific degree by assigning a severity level. To do this, specify syslog=level, where level is one of the string tokens given as valid severity levels in syslog(3C). You can omit the common LOG_ prefix on the severity level. Note that not all rctls support the syslog action. See resource_controls(5).
List information about rctls. The name, global event actions and statuses, and global flags are displayed. If one or more name operands are specified, only those rctls matching the names are displayed.
Configure resource controls based on the contents of /etc/rctladm.conf. Any name operands are ignored.
The following operands are supported:
The name of the rctl to operate on. Multiple rctl names can be specified. If no names are specified, and the list action has been specified, then all rctls are listed. If the enable or disable action is specified, one or more rctl names must be specified.
Example 1 Activating System Logging for Specific Violations
The following command activates system logging of all violations of task.max-lwps.
# rctladm -e syslog task.max-lwps #
Example 2 Examining the Current Status of a Specific Resource
The following command examines the current status of the task.max-lwps resource.
$ rctladm -l task.max-lwps task.max-lwps syslog=DEBUG $
The following exit values are returned:
A fatal error occurred. A message is written to standard error to indicate each resource control for which the operation failed. The operation was successful for any other resource controls specified as operands.
Invalid command line options were specified.
Each time rctladm is executed, it updates the contents of rctladm.conf with the current configuration.
See attributes(5) for descriptions of the following attributes:
By default, there is no global logging of rctl violations.