|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Express 11/10|
- administer Network Data Management Protocol activities
/usr/sbin/ndmpadm [-? ] subcommand [options] [direct-object]
The ndmpadm command can be used to query the ndmpd(1M) daemon to get the status of active sessions, terminate a session, query backup devices, and set or get the current NDMP (Network Data Management Protocol) service variables and properties. ndmpadm is implemented as a set of subcommands, many with their own direct object, which are described in the section for a given subcommand. Certain subcommands support options, which are described along with the subcommand.
The ndmpadm command supports the following subcommands:
Disable the specified authentication password handling.
Enable the specified authentication password handling.
Get the value of an NDMP configuration property.
Terminate an active session.
Set the value of an NDMP configuration property.
Get a list of tape devices connected to the server.
Display the details of active NDMP sessions.
The following option is supported:
Display a list of all subcommands and options.
The ndmpadm command supports the subcommands described below.
The syntax for the disable subcommand is:
# ndmpadm disable -a auth-type
This subcommand disables the authentication type specified by auth-type for an NDMP client's remote access. Valid values for auth-type are cram-md5 or cleartext.
The syntax for the enable subcommand is:
# ndmpadm enable -a auth-type -u username
This subcommand prompts for the user's password twice for confirmation and activates the specified authentication type with the given username and password for NDMP client access. Valid values for auth-type are cram-md5 or cleartext.
The syntax for the get subcommand is:
# ndmpadm get [-p] [property] [[-p] property=value]...
The property names are the same as used for the set subcommand and are described below. If you do not specify a property, the get subcommand returns all configuration properties.
The kill-sessions subcommand allows you to terminate the session number ID.
The syntax for the kill-sessions subcommand is:
# ndmpadm kill-sessions ID
The syntax for the set subcommand is:
# ndmpadm set [-p] property=value [[-p] property=value]...
The properties you can set with the set subcommand are described in the ndmp(4) man page.
The syntax for the show-devices subcommand is:
# ndmpadm show-devices
This subcommand lists the name, vendor, serial number, and other information about the current tape drive and libraries connected to the system.
The show-sessions subcommand displays details of a session. The syntax for the show-sessions subcommand is:
# ndmpadm show-sessions [-i tape,scsi,data,mover] [ID]
The show-sessions subcommand supports the following arguments:
Identify a type of interface about which to obtain data. If no interface is specified, show-sessions displays information for all types of interfaces.
Identifies a particular session about which to display data. If no ID is specified, show-sessions displays data for all sessions.
Example 1 Obtaining the Status of All NDMP Connections
The following command obtains status on all connections.
# ndmpadm show-devices
Example 2 Obtaining the Status of Certain Types of Connections
The following command obtains status on tape and SCSI interfaces.
# ndmpadm show-sessions -i scsi,tape
Example 3 Limiting Protocol Version
The following command limits the use of the NDMP protocol to version 3.
# ndmpadm set -p version=3
Example 4 Obtaining Current Version Number
The following command obtains the version number of the currently running NDMP.
# ndmpadm get -p version
Example 5 Disconnecting a Specific Session
The command shown below disconnects session 5. The session number was previously obtained from an ndmpadm show-sessions command.
# ndmpadm kill-session 5
Example 6 Obtaining the Values for All NDMP Properties
The following command obtains the values for all NDMP properties.
# ndmpadm get
Example 7 Enabling CRAM-MD5 Authentication
The following command enables CRAM-MD5 authentication.
# ndmpadm enable -a cram-md5 -u admin Enter new password:***** Re-enter password:*****
Example 8 Disabling Clear Text Password Authentication
The following command disables clear text password authentication.
# ndmpadm disable -a cleartext
An error occurred, such as the ndmpd daemon is not running, that prevented ndmpadm from contacting the demon.
Invalid command-line options were specified.
See attributes(5) for descriptions of the following attributes:
Administrative actions on this service, such as setting and getting a property can be alternatively performed using svccfg(1M). For example to enable Direct Access Recovery (DAR) mode:
# svccfg -s svc:/system/ndmpd svc:/system/ndmpd> setprop ndmpd/dar-support = yes
...and to get the list of properties:
# svccfg -s svc:/system/ndmpd svc:/system/ndmpd> listprop