|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Express 11/10|
- load a kernel module
modload [-p] [-e exec_file] filename
The modload command loads the loadable module filename into the running system.
filename is an object file produced by ld -r. If filename is an absolute pathname then the file specified by that absolute path is loaded. If filename does not begin with a slash (/), then the path to load filename is relative to the current directory unless the -p option is specified.
The kernel's modpath variable can be set using the /etc/system file. The default value of the kernel's modpath variable is set to the path where the operating system was loaded. Typically this is /kernel /usr/kernel.
For example, the following command looks for ./drv/foo:
example# modload drv/foo
The following command looks for /kernel/drv/foo and then /usr/kernel/drv/foo:
example# modload -p drv/foo
The following options are supported:
Specify the name of a shell script or executable image file that is executed after the module is successfully loaded. The first argument passed is the module ID (in decimal). The other argument is module specific. The module specific information is: the block and character major numbers for drivers, the system call number for system calls, or, for other module types, the index into the appropriate kernel table. See modinfo(1M)
Use the kernel's internal modpath variable as the search path for the module.
See attributes(5) for descriptions of the following attributes: