|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Express 11/10|
- terminfo compiler
tic [-v [n]] [-c] file
The command tic translates a terminfo file from the source format into the compiled format. The results are placed in the directory /usr/share/lib/terminfo. The compiled format is necessary for use with the library routines in curses(3CURSES).
If the environment variable TERMINFO is set, the compiled results are placed there instead of /usr/share/lib/terminfo.
Total compiled entries cannot exceed 4096 bytes. The name field cannot exceed 128 bytes. Terminal names exceeding 14 characters will be truncated to 14 characters and a warning message will be printed.
The following options are supported:
Specifies to check only file for errors. Errors in use= links are not detected.
Specify that (verbose) output be written to standard error trace information showing tic's progress. The optional integer n is a number from 1 to 10, indicating the desired level of detail of information. If n is omitted, the default level is 1. If n is specified and greater than 1, the level of detail is increased.
Contains one or more terminfo terminal descriptions in source format [see terminfo(4)]. Each description in the file describes the capabilities of a particular terminal. When a use=entry-name field is discovered in a terminal entry currently being compiled, tic reads in the binary from /usr/share/lib/terminfo to complete the entry. (Entries created from file will be used first. If the environment variable TERMINFO is set, that directory is searched instead of /usr/share/lib/terminfo.) tic duplicates the capabilities in entry-name for the current entry, with the exception of those capabilities that are explicitly defined in the current entry.
Compiled terminal description database
See attributes(5) for descriptions of the following attributes:
When an entry, for example, entry_name_1, contains a use=entry_name_2 field, any canceled capabilities in entry_name_2 must also appear in entry_name_1 before use= for these capabilities to be canceled in entry_name_1.