|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Express 11/10|
- partition manipulation program
parted [options] [device [options...]...]]
parted is a disk partitioning and partition resizing program. It allows you to create, destroy, resize, move, and copy ext2, ext3, linux-swap, FAT, FAT32, and reiserfs partitions. It can create, resize, and move Macintosh HFS partitions, as well as detect jfs, ntfs, ufs, and xfs partitions. It is useful for creating space for new operating systems, reorganizing disk usage, and copying data to new hard disks.
This manual page documents parted briefly. Complete parted documentation is distributed with the package in “GNU Info” format.
parted is implemented with a set of top-level options and a set of subcommands, most of which have their own options and operands. These subcommands are described below. parted has an optional operand:
The block device to be used. When none is given, parted uses the first block device it finds.
The following options are supported:
Displays a help message.
Prompts for user intervention.
Lists partition layout on all block devices.
Displays machine-parseable output.
Never prompts for user intervention.
Displays the version number.
If you omit a subcommand in a parted command line, the utility issues a command prompt.
Do a simple check on partition.
Copy the source partition's filesystem on source-device (or the current device if no other device was specified) to the dest partition on the current device.
Display general help, or help on a command, if specified.
Make a filesystem fs-type on partition. fs-type can be one of fat16, fat32, ext2, linux-wap, or reiserfs.
Create a new disk label (partition table) of label-type. label-type should be one of bsd, dvh, gpt, loop, mac, msdos, pc98, or sun.
Make a part-type partition with file system fs-type (if specified), beginning at start and ending at end (by default, in megabytes). fs-type can be one of fat16, fat32, ext2, HFS, linux-swap, NTFS, reiserfs, or ufs. part-type should be one of primary, logical, or extended.
Make a part-type partition with file system fs-type, beginning at start and ending at end (by default, in megabytes).
Move partition so that it begins at start and ends at end. Note that move never changes the minor number.
Set the name of partition to name. This option works only on Mac, PC98, and GPT disk labels. The name can be placed in quotes, if necessary.
Display the partition table.
Exit from parted.
Rescue a lost partition that was located somewhere between start and end. If a partition is found, parted will ask if you want to create an entry for it in the partition table.
Resize the file system on partition so that it begins at start and ends at end (by default, in megabytes).
Choose device as the current device to edit. device should usually be a Solaris or Linux hard disk device, but it can be a partition, software raid device, or an SVM or LVM logical volume if necessary.
Change the state of the flag on partition to state. Supported flags are: boot, root, swap, hidden, raid, lvm, lba, and palo. state should be either on or off.
Set unit as the unit to use when displaying locations and sizes, and for interpreting those given by the user when not suffixed with an explicit unit. unit can be one of s (sectors), B (bytes), kB, MB, GB, TB, % (percentage of device size), cyl (cylinders), chs (cylinders, heads, sectors), or compact (megabytes for input, and a human-friendly form for output).
Display version information and a copyright message.
See attributes(5) for descriptions of the following attributes:
The parted program is fully documented in the info(1) format GNU partitioning software manual.
This manual page was written by Timshel Knoll for the Debian GNU/Linux system. It is here adapted for the Solaris operating system.