|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Express 11/10|
- summarize file system ownership
quot [-acfhnv] filesystem...
quot -a [-cfhnv]
quot displays the number of blocks (1024 bytes) in the named filesystem (one or more) currently owned by each user. There is a limit of 2048 blocks. Files larger than this will be counted as a 2048 block file, but the total block count will be correct.
The following options are supported:
Generate a report for all mounted file systems.
Display three columns giving a file size in blocks, the number of files of that size, and a cumulative total of blocks containing files of that size or a smaller size.
Display three columns giving, for each user, the number of blocks owned, the count of number of files, and the user name. This option is incompatible with the -c and -v options.
Estimate the number of blocks in the file. This does not account for files with holes in them.
Attach names to the list of files read from standard input. quot -n cannot be used alone, because it expects data from standard input. For example, the pipeline
ncheck myfilesystem | sort +0n | quot -n myfilesystem
will produce a list of all files and their owners. This option is incompatible with all other options.
In addition to the default output, display three columns containing the number of blocks not accessed in the last 30, 60, and 90 days.
mount-point of the filesystem(s) being checked
See largefile(5) for the description of the behavior of quot when encountering files greater than or equal to 2 Gbyte ( 231 bytes).
Error condition (bad or missing argument, bad path, or other error).
Lists mounted file systems.
Used to obtain user names
See attributes(5) for descriptions of the following attributes:
This command can only be used by the super-user.