|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Express 11/10|
- select, report, import, export active print service on a system
print-service [-s service [-m] | -q | -e file | -i file]
The print-service utility manages print service selection, as well as export and import of basic print queue configuration.
Only a user root privileges or with the Printer Management profile can change the active print service or import print queue configuration.
The following options are supported:
Select the active print service for on a host. service can be one of lp or cups.
Migrate print queue configuration during print service selection.
Report the active print service on a host.
Export basic print queue configuration to a file.
Import basic print queue configuration from a file.
Example 1 Selecting a Print Service
The following command selects the CUPS print service as the active print service on a host.
# print-service -s cups
Example 2 Reporting the Active Print Service
The following command reports the active print service on a host.
# print-service -q
Example 3 Exporting a Print Queue Configuration
The following command exports the print queue configuration from the active print service.
# print-service -e /tmp/queues
Example 4 Importing a Print Queue Configuration
The following command imports the print queue configuration to the active print service.
# print-service -i /tmp/queues
An error occurred.
See attributes(5) for descriptions of the following attributes:
The print queue configuration saved and restored during export, import, and migration is limited to queue name and device name. It is likely that further configuration changes will be required before imported or migrated print queues become usable.