|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 11 Information Library|
- Chelsio Ethernet network interface controllers
The chxge Ethernet driver is a multi-threaded, loadable, clonable, STREAMS hardware driver supporting the connectionless Data Link Provider Interface, dlpi(7P), over Chelsio NIC controllers. Multiple (and mixed) NIC controllers installed within the system are supported by the driver. The chxge driver provides basic support for the NIC hardware. Functions include chip initialization, frame transmit and receive, and error recovery and reporting.
The cloning, character-special device /dev/chxge is used to access NIC devices installed within the system.
The chxge driver is dependent on /kernel/misc/gld, a loadable kernel module that provides the chxge driver with the DLPI and STREAMS functionality required of a LAN driver. See gld(7D) for more details on the primitives supported by the driver.
The values returned by the driver in the DL_INFO_ACK primitive in response to the DL_INFO_REQ are:
Default Maximum SDU is 1500 (ETHERMTU).
dlsap address length is 8.
MAC type is DL_ETHER.
The sap length value is -2, meaning the physical address component is followed immediately by a 2-byte sap component within the DLSAP address.
Broadcast address value is Ethernet/IEEE broadcast address (FF:FF:FF:FF:FF:FF).
Character special device.
SPARC chxge driver binary.
x86 platform kernel module. (32-bit).
x86 platform kernel module. (64-bit).
See attributes(5) for descriptions of the following attributes: