|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 11 Information Library|
- Sun Enterprise 10000 dynamic reconfiguration driver
The dynamic reconfiguration (DR) driver consists of a platform-independent driver and a platform-specific module. The DR driver uses standard features of the Solaris operating environment whenever possible to control DR operations and calls the platform specific module as needed. The DR driver creates minor nodes in the file system that serve as attachment points for DR operations.
The DR driver provides a pseudo-driver interface to sequence attach and detach operations on system boards using file system entry points referred to as ”attachment points.” The attachment point form depends on the platform.
On the Sun Enterprise 10000 server, the DR driver consists of a platform-independent driver (ngdr) and a platform-specific module (ngdrmach).
The domain configuration server (DCS) accepts DR requests from the system services processor (SSP) and uses the libcfgadm(3LIB) interface to initiate the DR operation. After the operation is performed, the results are returned to the SSP. For more information about the DCS on the Sun Enterprise 10000, refer to the dcs(1M) man page and the Sun Enterprise 10000 Dynamic Reconfiguration User Guide.
The DR driver creates physical attachment points for system board slots that takes the following form:
Where x represents the slot number (0 to 15) for a particular board.
Sun Enterprise 10000 Dynamic Reconfiguration User Guide