|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 11 Information Library|
- Intel i82365SL PC Card Interface Controller
The Intel i82365SL PC Card interface controller provides one or more PCMCIA PC card sockets. The pcic driver implements a PCMCIA bus nexus driver.
The driver provides basic support for the Intel 82365SL and compatible chips. Tested chips are:
Intel — 82365SL.
Cirrus Logic — PD6710/PD6720/PD6722.
Vadem — VG365/VG465/VG468/VG469.
Toshiba — PCIC and ToPIC
Ricoh — RF5C366/RL5C466/RL5C475/RL5C476/RL5C477/RL5C478.
02Micro — OZ6912/6972.
Texas Instruments — PCI1130/PCI1131/PCI1031/PCI1221/PCI1225/PCI1520/PCI 1410/PCI1420/PCI4520/PCI7510/PCI7621.
While most systems using one of the above chips will work, some systems are not supported due to hardware designs options that may not be software detectable.
Direct access to the PCMCIA hardware is not supported. All device access must be through the DDI.
Configuration of PC Card interface controllers are automatically done in the system by leveraging ACPI on x86 (or OBP on SPARC). Configuration includes allocation of device memory, I/O ports, CardBus subordinary bus number and interrupts. There is no user-interference required. Note that the controller may not work when ACPI is disabled.
There is one driver configuration property defined in the pcic.conf file:
This property must be defined and must be below 10.
pcic configuration file