|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 11 Information Library|
- SUNWixgb, 10 Gigabit Ethernet driver for Intel 82597ex controllers and Sun Ethernet PCI-X Adapter (X5544A-4) adapters.
The ixgb 10 Gigabit Ethernet driver is a multi-threaded, loadable, clonable, GLD-based STREAMS driver supporting the Data Link Provider Interface, DLPI on Intel 82597ex 10 Gigabit Ethernet controllers and Sun 10 Gigabit Ethernet PCI-X Adapter (X5544A-4) on x86 Platforms. The Intel 10G controller incorporates both MAC and PHY functions and provides 10G (fiber) Ethernet operation on the SR and LR connectors. The Sun 10 Gigabit Ethernet PCI-X Adapter (X5544A-4) is a 133 MHz PCI-X 10 Gigabit Ethernet card utilizing the Intel 82597EX PCI-X MAC controller with XFP-based 10GigE optics.
The ixgb driver functions include controller initialization, frame transmit and receive, promiscuous and multicast support and error recovery and reporting.
The ixgb driver and hardware support auto-negotiation, a protocol specified by the IEEE 802.3ae specification.
The following ixgb.conf configuration option is supported:
Upper limit on the maximum MTU size the driver allows. Intel 82597EX controller allows the configuration of jumbo frames. To configure jumbo frame, use ifconfig(1M). Use ifconfig with the adapter instance and the mtu argument (for example: ifconfig ixgb0 mtu 9000) to configure the adapter for the maximum allowable jumbo frame size. Allowed range is 1500 - 9000.
The cloning character-special device /dev/ixgb is used to access all Intel 10G controllers and Sun 10 Gigabit Ethernet PCI-X adapters (X5544A-4) installed within the system
You must send an explicit DL_ATTACH_REQ message to associate the opened stream with a particular device (PPA). The PPA ID is interpreted as an unsigned integer data type and indicates the corresponding device instance (unit) number. The driver returns an error (DL_ERROR_ACK) if the PPA field value does not correspond to a valid device instance number for the system. The device is initialized on first attach and de-initialized (stopped) at last detach.
The values returned by the driver in the DL_INFO_ACK primitive in response to the DL_INFO_REQ are:
Maximum SDU is 9000 (ETHERMTU, as defined in <sys/ethernet.h>).
Minimum SDU is 0.
DLSAP address length is 8.
MAC type is DL_ETHER.
SAP length value is -2 meaning the physical address component is followed immediately by a 2 byte SAP component within the DLSAP address.
Broadcast address value is Ethernet/IEEE broadcast address (FF:FF:FF:FF:FF:FF).
Once in the DL_ATTACHED state, you must send a DL_BIND_REQ to associate a particular Service Access Point (SAP) with the stream.
By default, the ixgb driver performs auto-negotiation to select the 10G link speed.
Special character device.
32-bit kernel module. (x86 only).
64-bit kernel module (x86 only).
See attributes(5) for descriptions of the following attributes:
IEEE 802.3ae 10 Gigabit Ethernet Specification — June, 2002
Sun 10 Gigabit Ethernet PCI-X Adapter (X5544A-4) Driver Installation Notes for Solaris
Writing Device Drivers
STREAMS Programming Guide
Network Interfaces Programmer's Guide