|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 11 Information Library|
- RAM disk device driver
Each ramdisk can be accessed either as a block device or as a raw device. When accessed as a block device, the normal buffering mechanism is used when reading from and writing to the device, without regard to physical disk records. Accessing the ramdisk as a raw device enables direct transmission between the disk and the read or write buffer. A single read or write call usually results in a single I/O operation, meaning that raw I/O is more efficient when many bytes are transmitted. You can find block files names in /dev/ramdisk. Raw file names are found in /dev/rramdisk.
There are no alignment or length restrictions on I/O requests to either block or character devices.
The argument features a bad address.
Invalid argument. EIO. An I/O error occurred.
Cannot create or delete a ramdisk without write permission on /dev/ramdiskctl.
The device does not support the requested ioctl function.
The device did not exist during opening.
Cannot exclusively open /dev/ramdiskctl. One or more ramdisks are still open.
A ramdisk with the indicated name already exists.
Cannot allocate resource for ramdisk. Try again later.
Block device for ramdisk named diskname.
Raw device for ramdisk name diskname
Driver configuration file. (Do not alter).
See attributes(5) for descriptions of the following attribute:
The percentage of available physical memory that can be allocated to ramdisks is constrained by the variable rd_percent_physmem. You can tune the rd_percent_physmem variable in /etc/system. By default, the percentage of available physical memory that can be allocated to ramdisks is fixed at 25%.
A ramdisk may not be the best possible use of system memory. Accordingly, use ramdisks only when absolutely necessary.