|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 11 Information Library|
- DTrace user instruction tracing provider
The fasttrap driver is a DTrace dynamic tracing provider that performs dynamic instrumentation of arbitrary instructions in Solaris processes. The fasttrap driver implements the DTrace fasttrap and pid providers.
The fasttrap driver is not a public interface and you access instrumentation offered by this provider through DTrace. Refer to the Solaris Dynamic Tracing Guide for a description of the public documented interfaces available for the DTrace facility and the probes offered by the fasttrap provider.
The fasttrap provider provides a DTrace probe that fires each time a user process executes an instruction. The pid provider allows for the dynamic creation of DTrace probes corresponding to instruction locations inside any user process specified using a process ID and an instruction address or symbol name. Together these providers permit DTrace users to perform instrumentation of Solaris user processes and to trace the interactions between processes and the operating system. See the chapter entitled “User Process Tracing" in the Solaris Dynamic Tracing Guide for information on how to use these providers to instrument processes.
See attributes(5) for a description of the following attributes:
Solaris Dynamic Tracing Guide