|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 11 Information Library|
- DTrace function boundary tracing provider
The fbt driver is a DTrace dynamic tracing provider that performs dynamic instrumentation at function boundaries in the Solaris kernel.
The function is the fundamental unit of program text. In a well-designed system, the function performs a discrete and well-defined operation on a specified object or series of like objects. Most functions are implemented by themselves calling functions on encapsulated objects, but some functions —so-called "leaf functions" — are implemented without making further function calls. The Function Boundary Tracing fbt provider contains a mechanism for instrumenting the vast majority of functions in the kernel and offering the instrumentation as a set of DTrace probes.
The fbt driver is not a public interface and you access the instrumentation offered by this provider through DTrace. Refer to the Solaris Dynamic Tracing Guide for a description of the public documented interfaces available for the DTrace facility and the probes offered by the fbt provider.
See attributes(5) for a description of the following attributes:
Solaris Dynamic Tracing Guide