|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 11 Information Library|
- Instant Image control device
The ii device is a control interface for Instant Image devices and controls the Instant Image module through the ioctl(2) interface.
Instant Image is a point-in-time volume copy facility for the Solaris operating environment that is administered through the iiadm(1M) command. With Instant Image, you can create an independent point-in-time copy of a volume or a master volume-dependent point-in-time view. You can also independently access the master and shadow volume for read and write operations. Instant Image also lets you update the shadow volume from the master volume or restore the master volume from the shadow. (Restore operations to volumes can be full or incremental). Instant Image supports fast volume re-synchronization, letting you create a new point-in-time volume copy by updating the specified volume with only changed data.
To create a shadow volume you need a:
Master volume to be shadowed.
Shadow volume where the copy will reside. This volume must be equal to or larger than the master volume.
Administrative bitmap volume or file for tracking differences between the shadow and master volumes. The administrative bitmap volume or file must be at least 24Kbytes in size and requires 8KBytes for each GByte (or part thereof) of master volume size, plus an additional 8KBytes overhead. For example, to shadow a 3GByte master volume, the administration volume must be 8KBytes + (3 * 8KBytes) =32KBytes in size.
The Instant Image module uses services provided by the SDBC and SD_GEN modules. The SV module is required to present a conventional block device interface to the storage product interface of the Instant Image, SDBC and SD_GEN modules.
When a shadow operation is suspended or resumed, the administration volumes may be stored in permanent SDBC storage or loaded and saved to and from kernel memory. The ii_bitmap variable in the /kernel/drv/ii.conf configuration file determines the administration volume storage type. A value of 0 indicates kernel memory, while a value of 1 indicates permanent SDBC storage. If the system is part of a storage products cluster, use the 1 value (permanent storage), otherwise use kernel memory (0 value).
32– bit ELF kernel module (x86).
See attributes(5) for a description of the following attributes: